Results 1 to 5 of 5

Thread: Intermittent micro freezes

  1. #1
    Basic Member
    Join Date
    Mar 2017
    Posts
    3

    Intermittent micro freezes

    Starting on the 9th March (so about 9 days ago) I have been experiencing ~1-2 second freezes every couple of minutes in Normal/Ranked matches only (no issues at all in lobby's or 1v1 games).

    It doesn't appear to be network related - net graph is showing no packet loss and constant ping.
    PC specs aren't an issue (i5-7600K, GTX1060, 16GB ram) - plus the game was running fine for a couple of months prior to issues. I've also run a few benchmarks/stress tests and everything's working fine.

    Uninstalled/reinstalled Dota and steam. Tried reinstalled the game on a different hard drive in case that was causing an issue but no luck there either.

    No other games are having issues.

    Steam ID: 76561198016208158

    If anyone has any suggestions, I'd love to hear them!
    Also, first post so if I've done something wrong - sorry, let me know and I'll try get it right

  2. #2
    Basic Member aveyo's Avatar
    Join Date
    Aug 2012
    Location
    EU West
    Posts
    2,410
    You say it isn't, but it most likely is network-related, so not much you can do about it, except fiddling with the router / wireless / using ethernet connection. The so-called net graph in-game is unreliable (the real net-graph is accessible using launch option -vconsole).
    In case its a render/vsync issue, add launch option: -dx11
    That is, if you are on Windows OS (I suspect you are, but next time a more complete system description should be provided - the kind that a dxdiag text report would be)

  3. #3
    Basic Member
    Join Date
    Mar 2017
    Posts
    3
    Thanks aveyo! I think you're right about it being network related. The -vconsole graph showed it pretty clearly (for anyone else who stumbles across this thread, I used the "consoletool netgraph" command in vconsole).

    Here's my normal game play (no freezes):
    Normal.png
    And here's the graph from when I experienced a couple of freezes:
    Freezes.png

    My interpretation of the graph is that it says zero packet loss, so those big spikes are basically very high pings. I'm not really sure if my normal is normal . I'm also not sure what all of the different colours are...
    Next time i'll include more complete system specs, but you were correct to assume Windows OS (win10). I'm also using a Ethernet connection.

    My next question is, is this caused my something my end or something server end? Do you know of any checks I can run to try and isolate what's causing the problem?
    It seems particularly strange to me that I can't reproduce it in lobby's or in 1v1 games but it happens dozens of times in every normal match game, which is why I ask about server end. I'm not sure if it's relevant, but all of my games are on Australian servers.

    Thanks again!
    Last edited by Diseased7; 03-21-2017 at 02:04 AM.

  4. #4
    Basic Member aveyo's Avatar
    Join Date
    Aug 2012
    Location
    EU West
    Posts
    2,410
    It appears to be more server-related but I cannot vouch for that.
    You should try playing in some other region (SEA I guess?) even with higher ping, just to rule out a particular routing problem / server cluster issue.


    The reds are for entities - most network traffic is used for that, but some are also client-side, so it would not harm to use -dx11 launch option as it's more robust in general.
    Gaps are definitely packet loss, but probably under 1%.

  5. #5
    Basic Member
    Join Date
    Mar 2017
    Posts
    3
    Thanks again for your help!

    I tried a different server and no luck there. I'll hassle my ISP and see what they can do.

    I did try the -dx11 launch option but it didn't help at all (the graphs I posted before had the -dx11 option on).

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •