Results 1 to 7 of 7

Thread: DOTA 2 Nvidia SLI Rendering/Flickering Potential Fix

  1. #1
    Basic Member
    Join Date
    Nov 2011
    Posts
    44

    DOTA 2 Nvidia SLI Rendering/Flickering Potential Fix

    I'm not sure if anyone else has posted something like this before. All my previous attempts at finding something came up short. I found someone on the official steam forums that did this same thing for Rail Simulator 2012 (I think) and I decided to just go ahead and try the same thing, but with DOTA 2.

    The below is my text from the official nvidia forums for the latest Nvidia 310.70 WHQL Candidate Driver Release Feedback Thread :
    "I previously posted about DOTA 2 SLI problems and think I found a fix. After doing some investigating, I found a solution someone was using for a different game, but with very similar problems.

    initial post can be seen @ https://forums.geforce.com/default/t...set=47#3717496

    What I ended up doing was downloading the latest nvidia inspector. I changed my values for a few options. (see below)

    'Number of GPUs to use on SLI rendering mode' : SLI_GPU_COUNT_TWO
    'Nvidia predefined number of GPUs to use on SLI rendering mode' : SLI_PREDEFINED_GPU_COUNT_TWO
    'Nvidia Predefined SLI mode' : SLI_PREDEFINED_MODE_FORCE_AFR2
    'SLI rendering mode' : SLI_RENDERING_MODE_FORCE_AFR2

    Changing all 4 of those settings took me from 6-14 fps on the main menu to my supposed-to-be 120 fps.
    In-game playing maxes out at 120 as it should as well with the occasional frame drop or two (only when there should be). If not a 100% fix, I'm satisfied with it and it is playable again this way."

    What I didn't mention was the screen flickering for my PC was also fixed by changing those settings. Overall it just boosted my performance across the board. I hope this information can help other users with the same problems I have been experiencing.

  2. #2
    Basic Member
    Join Date
    Apr 2012
    Posts
    6
    Seems to have solved the flickering for me too (670gtx sli).

  3. #3
    Basic Member
    Join Date
    Dec 2011
    Posts
    30
    I just get Lenovo Y500 with 2 650M Sli and have some gliches and wol fps too. Around 25-30. What i do to fix the problem and have nicely 100 FPS.
    Get Nvidia Inspector lates version. Finde "Driver Version". 314.07 WHQ is the lates. On the right side of the box have another button who open profile manu.
    Choose "Dota 2" profile and press applay.
    Play the game without any problem

    P.S One more think which i found very helpful in this situation. From Nvidia Control Panel > Set SLI and PhysX Configuration > PhysX Settings > Choose one of the two video cards ( don't leave it "autodetect"). I don't recommend to check box "Dedicate to PhysX", but this is your choice.
    Last edited by lockwars; 03-25-2013 at 10:26 AM.

  4. #4
    Yup this worked for me.

    I had to edit the default profile it selects (_GLOBAL_DRIVER_PROFILE (Base Profile))
    I did try the dota 2 one but it didn't change anything (i'm assuming it isn't recognising that dota is opening so it isn't applying the profile)
    Either way it's fine since it was doing the same in tf2 as well.

    Thanks for posting this.

  5. #5
    Basic Member
    Join Date
    Apr 2013
    Posts
    2
    I have the same problem, im trying to apply the dota 2 settings but nothing seems to happend, i would not like to edit my global setting so anybody knows how to fix that?

  6. #6
    Basic Member
    Join Date
    Apr 2013
    Posts
    3
    hi, i got the same issue, did you fix that?

  7. #7
    Basic Member
    Join Date
    Oct 2012
    Posts
    1
    Try enabling borderless window in dota settings. It worked for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •