Announcement

Collapse

Forum Rules

  • No flaming or derogatory remarks, directly or through insinuation.
  • No discussion, sharing or referencing illegal software such as hacks, keygen, cracks and pirated software.
  • No offensive contents, including but not limited to, racism, gore or pornography.
  • No excessive spam/meme, i.e. copious one liners in a short period of time, typing with all caps or posting meme responses (text/image).
  • No trolling, including but not limited to, flame incitation, user provocation or false information distribution.
  • No link spamming or signature advertisements for content not specific to Dota 2.
  • No Dota 2 key requests, sell, trade etc.
  • You may not create multiple accounts for any purpose, including ban evasion, unless expressly permitted by a moderator.

  • Please search before posting. One thread per issue. Do not create another thread if there is an existing one already.
  • Before posting anything, make sure you check out all sticky threads (e.g., this). Do not create new threads about closed ones.
  • It is extremely important that you post in correct forum section.

  • Balance discussion only in Misc.
  • All art related (such as hero model) feedbacks go to Art Feedback Forum.
  • All matchmaking feedback should go here: Matchmaking Feedback
  • All report/low priority issues should go here: Commend/Report/Ban Feedback
  • No specific workshop item feedback. These should go to workshop page of that item.
  • When posting in non-bugs section (such as this), use [Bugs], [Discussion] or [Suggestion] prefix in your thread name.



In case you object some action by a moderator, please contact him directly through PM and explain your concerns politely. If you are still unable to resolve the issue, contact an administrator. Do not drag these issues in public.



All rules are meant to augment common sense, please use them when not conflicted with aforementioned policies.
See more
See less

[Fixed] Ember spirit cannot function properly after a remnant failure.

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Fixed] Ember spirit cannot function properly after a remnant failure.

    Now i've read about some bugs being with ember spirit's revenant's and teleporting failures.
    However i think this is a bit different than the others.

    Summary: Being unable to attack, move, use sleight of fist or activate Fire Remnant after having used it. Until i'm killed and revived.

    Repro: Hard to say.

    Result: Being a bit stuck. Seemed tp scroll worked, though. But still a game-changing bug where one cannot attack the enemy.

    Expected result: Being able to move, attack, use sleight of fist and activate Fire Remnant.


    Matchid: 388729689 at ~0:40..

  • #2
    I also experienced this same issue, I might hunt down the match id later on and post here. I actually couldn't even TP the first time I tried. But then, after a minute or so, I could (which makes even less sense).

    Comment


    • #3
      The replay from the OP does indeed show him getting stuck at about 39:55 (replay time). At 40:13 the combat log shows that even a cog push from Clockwerk (which interrupted his TP) isn't moving him (though he doesn't seem to be close enough to the cogs to get hit at all).

      I don't think it can be due to the scenery, because the pole thing he stands next to is normally completely passable, as far as I can tell.

      Oh, and at 40:55 a creep gets stuck in a nearby position.
      Last edited by Fizz; 11-17-2013, 04:55 PM.
      Fizz on dev.dota2.com / Jimmy M on Youtube (a pseudonym)

      Comment


      • #4
        Note for future readers: there's another report of this here:
        http://dev.dota2.com/showthread.php?t=114708
        Fizz on dev.dota2.com / Jimmy M on Youtube (a pseudonym)

        Comment


        • #5
          Sorry for bumping this, but it happened to me. I was stuck by Disruptor's kinect field, used remnant, got stuck forever, lost the game because free kill.
          http://www.youtube.com/user/swordzzzzz

          Comment


          • #6
            Happened to me today. I was freed via force staff from ally. Sorry for bumping as well but any other workarounds discovered for this issue in the interim? Thanks.

            Match ID: 470083611 (All Pick)
            Date and Time: Jan 16/ 1:01:40AM (GMT +8)
            Spanned from: 59:57 to 62:65 mark.

            Comment


            • #7
              are you sure you are not trapped on a cliff or something

              Comment


              • #8
                dota2://matchid=587947459&matchtime=2800

                I count exactly 45 seconds between when I cast my remnant and when I activated it, so that's more evidence for the the "remnant expired as you were in flight" hypothesis.

                Comment


                • #9
                  dota2://matchid=598799573&matchtime=1210 (~20 min)

                  Just happened to me, I wanted to go on my remants, but instead I get instant TP on it (no travelling animation) and get stuck unable to do anything (except using my phase boots, so I guess it doesnt apply to items).

                  I have no idea how to trigger the glitch, I was just backing then coming back from fountain.

                  Comment


                  • #10
                    The same thing happened to me here's the ID 600485470

                    But another bug happened too..

                    Right after i sleighted a clinkz my hero model wouldn't show up.. I could move use spells everything normally, just the hero model wouldn't appear.

                    So the getting stuck glitch happens at around 10 min mark in game time and the hero model dissappearance happens(and the glitch was visible to at least my team) at around 26 min mark in game

                    Comment


                    • #11
                      Yeah I remember this happening to me back in November too. In my case, OD astral'd me right as I activated a remnant to run to it.

                      When the astral finished, I warped to the remnant, but after that I was stuck in place just like the OP.

                      It could be that during the OD astral, my remnant faded. So the problem might be that some abilities which delay the warping process need to cancel the warp, or maintain the remnant etc until its used. Not sure what the exact fix should be though.
                      Last edited by cinephile; 04-08-2014, 01:47 PM.
                      "It can't be bargained with. It can't be reasoned with. It doesn't feel pity, or remorse, or fear. And it absolutely will not stop, ever, until you are dead."
                      Io, the Guardian Wisp

                      Comment


                      • #12
                        Although this was reported fixed in the Spring Cleaning update, there are reports that this still happens, e.g. this was posted on Reddit today:

                        http://www.youtube.com/watch?v=KPiCu0nJn1o

                        The game was played yesterday: 716397844 at 14:38.

                        The timing makes it seem like the remnant expired just as the dash was happening.
                        Last edited by Fizz; 06-14-2014, 03:46 AM.
                        Fizz on dev.dota2.com / Jimmy M on Youtube (a pseudonym)

                        Comment


                        • #13
                          Re-added.
                          Please, just call me buny.

                          Comment


                          • #14
                            In fact, I was able to reproduce this by casting the dash exactly as the remnant expired. It's not that difficult if you note carefully the timer on the buff that casting a remnant gives you. (I took about 4 attempts.)

                            So I think we have the cause: casting the dash ("Activate Fire Remnant") as the remnant expires.

                            I think it's easier to reproduce if there's a large distance between yourself and the remnant (unsure).

                            If the bug triggers, it transports you to the location of a previous remnant (which of course will also have expired or been used) or to the centre of the map (coordinates 0,0).

                            For example, in the replay 716397844 above, he actually gets transported to the location of a remnant he had cast (and used) at 13:40 replay time.
                            Last edited by Fizz; 06-14-2014, 11:51 AM.
                            Fizz on dev.dota2.com / Jimmy M on Youtube (a pseudonym)

                            Comment


                            • #15
                              The distance shouldnt matter much, since it takes about same time to reach the remnants, no matter how far or close. You get either moved by 1.3k ms or reach the remnant in 0.4 seconds, whichever is faster.
                              Please, just call me buny.

                              Comment

                              Working...
                              X