Edit: I have *partially* fixed the issue. It seems (though I am still not 100% sure) to have been related to the alpha channel of some of the .tga images. I made 32 images with progressively more blur intensity. I used the image's combined RGB channel as the alpha channel. From my testing, after 16 images, the compiler starts giving me errors on compile. I think after 16 stages of blur, the pixels in the alpha channel are too blurred/diffused. Although, I don't think this is the entire issue, since each of the individual 32 .tga source files can be converted to individual .vtexs without issue. However, it seems that when they are packaged and/or converted by proxy of the .mks file, they don't compile properly, probably due to some conversion issue.

I have come across an issue recently where it is impossible to create new sprite sheets for animated sprites used in particle effects. I can compile regular .vtex files that point to a .tga/.png/.psd just fine, but resourcecompiler/the engine no longer recognizes .mks (the file format required to compile for multi-sequence/multi-frame sprites) as a valid file and struggles to find "the best packaging" for this type of file when compiling a .vtex into a .vtex_c, as seen in this screenshot:

Additionally, this error is spewed constantly in vconsole if the engine is attempting to compile the .vtex file from the asset browser:
c:\buildslave\source2_dota_rel_win64\build\src\rendersystem\texturebase.cpp(2496):ResourceHandleToData( materials/particle/sprite_blur_sheet/sprite_blur_sheet.vtex ) failed! Falling back to error texture!
It seems as though a recent, or perhaps not-very-recent (since I have not attempted to compile a .vtex with an .mks file reference since 2015, when it still worked) update might have broken this functionality. I have linked a googledrive download link for the files I'm working with (the attachment function on this forum doesn't want to upload the zip for some reason) in case anyone wants to take a look at them and try to compile for themselves: https://drive.google.com/open?id=1F6...yOfQJaGpnwMeXG