I've had several problems with Diretide Recipes. The first time I used the basic Materialize Item recipe it worked fine. So I tried the Augment Common Item recipe. I put in 2 commons, but when i tried to insert the third and complete the recipe, the third item became greyed out. I can't remove any of the items from the recipe now, and the recipe (with the items inside) is still in my inventory, but I can't complete it or remove the items.

Later on I tried a Cursed Recipe: Materialize Item. I put in my 4 essences and completed the recipe, and was told I got some Cursed SB shoulders. Sweet. Went to look for them, not there. Essences are gone, recipe is gone, item isn't there, and now my Armory wont sort at all under any sorting option. The spaces where the essences were before the recipe was used are permanently empty.

Also having some problems with Diretide sporadically not giving me any items upon completion, but I'm sure that's a separate issue.

If someone could look into these recipe bugs that would be super sweet.

Thanks,
--Caketown