Announcement

Collapse

Forum Rules

  • No flaming or derogatory remarks, directly or through insinuation.
  • No discussion, sharing or referencing illegal software such as hacks, keygen, cracks and pirated software.
  • No offensive contents, including but not limited to, racism, gore or pornography.
  • No excessive spam/meme, i.e. copious one liners in a short period of time, typing with all caps or posting meme responses (text/image).
  • No trolling, including but not limited to, flame incitation, user provocation or false information distribution.
  • No link spamming or signature advertisements for content not specific to Dota 2.
  • No Dota 2 key requests, sell, trade etc.
  • You may not create multiple accounts for any purpose, including ban evasion, unless expressly permitted by a moderator.

  • Please search before posting. One thread per issue. Do not create another thread if there is an existing one already.
  • Before posting anything, make sure you check out all sticky threads (e.g., this). Do not create new threads about closed ones.
  • It is extremely important that you post in correct forum section.

  • Balance discussion only in Misc.
  • All art related (such as hero model) feedbacks go to Art Feedback Forum.
  • All matchmaking feedback should go here: Matchmaking Feedback
  • All report/low priority issues should go here: Commend/Report/Ban Feedback
  • No specific workshop item feedback. These should go to workshop page of that item.
  • When posting in non-bugs section (such as this), use [Bugs], [Discussion] or [Suggestion] prefix in your thread name.



In case you object some action by a moderator, please contact him directly through PM and explain your concerns politely. If you are still unable to resolve the issue, contact an administrator. Do not drag these issues in public.



All rules are meant to augment common sense, please use them when not conflicted with aforementioned policies.
See more
See less

Borderless Fullscreen Not Working With Vulkan Rendering API

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Borderless Fullscreen Not Working With Vulkan Rendering API

    Hello all,

    Not sure when the issue started precisely (sometime between December 1st and today, since the issue only started to happen when I launched Dota tonight). When I launch Dota, despite having Vulkan enabled for months now, it automatically forces the choice under "Resolution" to "Use my monitor's current resolution," despite having had selected "Use advanced settings" with "1920x1080 (144hz) and "Borderless Window" for years. This persists even after I change the settings and restart Dota - it will revert back to "Use my monitor's current resolution." This, of course, adds a bit of annoyance any time I try to alt-tab out of Dota, as it takes a second or two to switch out of Fullscreen and to whatever window I switched to. The bug is only partially there if I switch the rendering API to DX11. While it still forces the option to "Use my monitor's current resolution," it appears that it still functions under Borderless Window, rather than Exclusive Fullscreen.

    I'll link a short video here that should hopefully show what I'm talking about.
    https://my.mixtape.moe/bgugrn.webm

    Here's a screenshot of my specs to hopefully show that I'm not running Dota on a potato and therefore shouldn't be having these problems, I guess?
    https://my.mixtape.moe/tbavws.PNG

    Things I've tried:
    - Switching the Rendering API from Vulkan to DX11
    -- Works, but not ideal. I would rather use Vulkan.
    - Putting "-windowed -noborder" in Dota's launch options via Steam
    -- Does nothing, as far as I can tell.
    - Verified the integrity of the game cache.
    -- Made me feel good about myself, but unfortunately did nothing.

    Any help would be appreciated!

  • #2
    First, that's a malware-infested non-standard domain that is blocked by most isp's and nameservers (so no, I could not reach any of your supplied details).

    Second, what exactly is the issue with it?
    It has done so for couple years now - if the current display resolution is the same with the game resolution, it switches to Use my monitor's current resolution.
    Are you saying that your current display resolution is not [email protected]? Then yes, it's a problem.

    The game updates frequently, but so do GPU drivers and Windows itself.
    The very first thing to do would be to disable Windows Game Bar, DVR and Game mode.
    Then, File Explorer to \steamapps\common\dota 2 beta\game\bin\win64\ and Alt+Enter - Compatibility - Disable fullscreen optimizations = checked on the dota2.exe.
    Also make sure stuff like GeforceExperience is not altering your configuration on-the-fly i.e. disable any profile for DOTA

    -windowed is not a thing anymore. Try instead: -vulkan -noborder -w 1920 -h 1080

    Might be a good idea to add launch option: -autoconfig_level 2
    Run the game once, then remove the above option.
    Troubleshooting crashes
    Dota 2 Resources: autoexec.cfg reference / benchmark.cfg / Tweak it yourself (launch options, cvars) / useful batch files
    No-Bling GlanceValue & FPS ++ NEW! Panorama hotkeys NEW! dota_primary_mm_language_override NEW TOGGLE_QUICKCAST_TP.bat NEW FIX LEGACY KEYS YOURSELF! NEW Toggle UI Animations OFF

    Comment


    • #3
      Originally posted by aveyo View Post
      First, that's a malware-infested non-standard domain that is blocked by most isp's and nameservers (so no, I could not reach any of your supplied details).

      Second, what exactly is the issue with it?
      It has done so for couple years now - if the current display resolution is the same with the game resolution, it switches to Use my monitor's current resolution.
      Are you saying that your current display resolution is not [email protected]? Then yes, it's a problem.

      The game updates frequently, but so do GPU drivers and Windows itself.
      The very first thing to do would be to disable Windows Game Bar, DVR and Game mode.
      Then, File Explorer to \steamapps\common\dota 2 beta\game\bin\win64\ and Alt+Enter - Compatibility - Disable fullscreen optimizations = checked on the dota2.exe.
      Also make sure stuff like GeforceExperience is not altering your configuration on-the-fly i.e. disable any profile for DOTA

      -windowed is not a thing anymore. Try instead: -vulkan -noborder -w 1920 -h 1080

      Might be a good idea to add launch option: -autoconfig_level 2
      Run the game once, then remove the above option.
      Here, I uploaded the content to a more standard source. Sorry about that.

      https://youtu.be/6RrH-em4D4o
      This shows what I'm referring to in that it's not saving my borderless fullscreen setting. Every time the screen goes black, that's Dota either leaving or returning to exclusive fullscreen. This also happens with your suggested launch options, unfortunately.

      https://i.imgur.com/7lGRPt8.png - my PC's specs.

      I went through the standard procedures otherwise - Windows itself is up to date, all Xbox related stuff (game bar, DVR, game mode, etc.) is disabled entirely, my GPU driver is up to date, and I also tried that fullscreen optimizations checkbox. No dice.

      Comment


      • #4
        Looks like automatic switching depending on content type (this only happens with HDMI and DisplayPort connectors, not with DVI).
        You can disable that behavior by going to Nvidia Control Panel - Display - Adjust Desktop Colour Settings - Content type reported to the display: Desktop programs
        Do it for your other 60Hz monitor as well. I suspect that's the main issue, having miss-matched Hz displays. If you were to disconnect that monitor, I think all your problems would go away.

        But it can still be an external program triggering it (like the mentioned Geforce Experience, or the regular per-application Nvidia Control Panel forcing something like DSR or VSync ON, or some other GPU OC or recording software).

        Anyway, it should still be borderless window, not exclusive fullscreen.
        Easy to test that by adjusting the windows volume with media keys Volume+/-/Mute - if it were exclusive fullscreen, you would not see an OSD for these.
        Last edited by aveyo; 12-05-2018, 05:43 AM.
        Troubleshooting crashes
        Dota 2 Resources: autoexec.cfg reference / benchmark.cfg / Tweak it yourself (launch options, cvars) / useful batch files
        No-Bling GlanceValue & FPS ++ NEW! Panorama hotkeys NEW! dota_primary_mm_language_override NEW TOGGLE_QUICKCAST_TP.bat NEW FIX LEGACY KEYS YOURSELF! NEW Toggle UI Animations OFF

        Comment


        • #5
          Originally posted by aveyo View Post
          Looks like automatic switching depending on content type (this only happens with HDMI and DisplayPort connectors, not with DVI).
          You can disable that behavior by going to Nvidia Control Panel - Display - Adjust Desktop Colour Settings - Content type reported to the display: Desktop programs
          Do it for your other 60Hz monitor as well. I suspect that's the main issue, having miss-matched Hz displays. If you were to disconnect that monitor, I think all your problems would go away.

          But it can still be an external program triggering it (like the mentioned Geforce Experience, or the regular per-application Nvidia Control Panel forcing something like DSR or VSync ON, or some other GPU OC or recording software).

          Anyway, it should still be borderless window, not exclusive fullscreen.
          Easy to test that by adjusting the windows volume with media keys Volume+/-/Mute - if it were exclusive fullscreen, you would not see an OSD for these.
          Unfortunately, it doesn't look like I'm getting that option with either of my displays. That option sounds like it would fix the issue (along with other miscellaneous things that have been bothering me for a while), but it's simply not there.
          https://i.imgur.com/iXQtcbS.png

          I can tell you that any OSD that would normally show up via borderless (the alt-tab window, volume, Action Center notifications, etc.) are not showing up, so it's most certainly still in exclusive fullscreen. I'm also not seeing any meddling coming from either Nvidia Control Panel or the GeForce Experience.

          Comment


          • #6
            So it's indeed Exclusive Fullscreen. Bummer!
            Have you tried disabling Steam In-game overlay? That's another thing that cross my mind

            Might very well be that Vulkan renderer is broken. I don't have hardware to test it myself, but it used to be that -vulkan -autoconfig launch options would disable fullscreen mode.
            Troubleshooting crashes
            Dota 2 Resources: autoexec.cfg reference / benchmark.cfg / Tweak it yourself (launch options, cvars) / useful batch files
            No-Bling GlanceValue & FPS ++ NEW! Panorama hotkeys NEW! dota_primary_mm_language_override NEW TOGGLE_QUICKCAST_TP.bat NEW FIX LEGACY KEYS YOURSELF! NEW Toggle UI Animations OFF

            Comment

            Working...
            X