Announcement

Collapse

Forum Rules

  • No flaming or derogatory remarks, directly or through insinuation.
  • No discussion, sharing or referencing illegal software such as hacks, keygen, cracks and pirated software.
  • No offensive contents, including but not limited to, racism, gore or pornography.
  • No excessive spam/meme, i.e. copious one liners in a short period of time, typing with all caps or posting meme responses (text/image).
  • No trolling, including but not limited to, flame incitation, user provocation or false information distribution.
  • No link spamming or signature advertisements for content not specific to Dota 2.
  • No Dota 2 key requests, sell, trade etc.
  • You may not create multiple accounts for any purpose, including ban evasion, unless expressly permitted by a moderator.

  • Please search before posting. One thread per issue. Do not create another thread if there is an existing one already.
  • Before posting anything, make sure you check out all sticky threads (e.g., this). Do not create new threads about closed ones.
  • It is extremely important that you post in correct forum section.

  • Balance discussion only in Misc.
  • All art related (such as hero model) feedbacks go to Art Feedback Forum.
  • All matchmaking feedback should go here: Matchmaking Feedback
  • All report/low priority issues should go here: Commend/Report/Ban Feedback
  • No specific workshop item feedback. These should go to workshop page of that item.
  • When posting in non-bugs section (such as this), use [Bugs], [Discussion] or [Suggestion] prefix in your thread name.



In case you object some action by a moderator, please contact him directly through PM and explain your concerns politely. If you are still unable to resolve the issue, contact an administrator. Do not drag these issues in public.



All rules are meant to augment common sense, please use them when not conflicted with aforementioned policies.
See more
See less

Dota 2 Reborn doesn't load (Linux)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dota 2 Reborn doesn't load (Linux)

    My normal Dota 2 loads just fine, but I can't open reborn. Its a fresh install of both Dota 2 and the Dota 2 Reborn Beta counterpart. I tried verifying the game files. Didn't work. Is there any solution to this?

    Running Ubuntu 14.10..

  • #2
    same here. Ubuntu 15.04

    Comment


    • #3
      Ubuntu 15.04
      Crashing the game after connecting to server.
      Sorry for my english ))

      Comment


      • #4
        I get the following:

        ERROR: apport (pid 1916) Sat Jun 27 23:46:06 2015: called for pid 1911, signal 11, core limit 0
        ERROR: apport (pid 1916) Sat Jun 27 23:46:06 2015: executable: /home/bednar/.steam/steam/steamapps/common/dota 2 beta/game/bin/linuxsteamrt64/dota2 (command line "/home/bednar/.steam/steam/steamapps/common/dota\ 2\ beta/game/bin/linuxsteamrt64/dota2")
        ERROR: apport (pid 1916) Sat Jun 27 23:46:06 2015: executable does not belong to a package, ignoring

        Comment


        • #5
          I cannot launch DotA 2 Reborn either (Ununtu 14.04). I get following messages:
          Code:
          Game update: AppID 570 "Dota 2", ProcID 18783, IP 0.0.0.0:0
          ERROR: ld.so: object '/home/battery/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
          
          (steam:17504): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
          
          (steam:17504): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
          
          (steam:17504): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
          
          (steam:17504): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
          
          (steam:17504): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
          
          (steam:17504): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
          
          (steam:17504): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
          
          (steam:17504): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
          
          (steam:17504): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
          
          (steam:17504): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
          
          (steam:17504): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
          
          (steam:17504): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
          
          (steam:17504): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
          ERROR: ld.so: object '/home/battery/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
          pid 18786 != 18785, skipping destruction (fork without exec?)
          ERROR: ld.so: object '/home/battery/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
          ERROR: ld.so: object '/home/battery/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
          Using breakpad crash handler
          Setting breakpad minidump AppID = 570
          Forcing breakpad minidump interfaces to load
          Looking up breakpad interfaces from steamclient
          Calling BreakpadMiniDumpSystemInit
          Looking up breakpad interfaces from steamclient
          Calling BreakpadMiniDumpSystemInit
          Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198049354268 [API loaded yes]
          Steam_SetMinidumpSteamID:  Setting Steam ID:  76561198049354268
          Setting breakpad minidump AppID = 373300
          Could not find required OpenGL entry point 'glUseProgramStages'!
          Could not find required OpenGL entry point 'glActiveShaderProgram'!
          Could not find required OpenGL entry point 'glCreateShaderProgramv'!
          Could not find required OpenGL entry point 'glBindProgramPipeline'!
          Could not find required OpenGL entry point 'glDeleteProgramPipelines'!
          Could not find required OpenGL entry point 'glGenProgramPipelines'!
          Could not find required OpenGL entry point 'glIsProgramPipeline'!
          Could not find required OpenGL entry point 'glProgramParameteri'!
          Could not find required OpenGL entry point 'glGetProgramPipelineiv'!
          Could not find required OpenGL entry point 'glProgramUniform1i'!
          Could not find required OpenGL entry point 'glProgramUniform2i'!
          Could not find required OpenGL entry point 'glProgramUniform3i'!
          Could not find required OpenGL entry point 'glProgramUniform4i'!
          Could not find required OpenGL entry point 'glProgramUniform1ui'!
          Could not find required OpenGL entry point 'glProgramUniform2ui'!
          Could not find required OpenGL entry point 'glProgramUniform3ui'!
          Could not find required OpenGL entry point 'glProgramUniform4ui'!
          Could not find required OpenGL entry point 'glProgramUniform1f'!
          Could not find required OpenGL entry point 'glProgramUniform2f'!
          Could not find required OpenGL entry point 'glProgramUniform3f'!
          Could not find required OpenGL entry point 'glProgramUniform4f'!
          Could not find required OpenGL entry point 'glProgramUniform1d'!
          Could not find required OpenGL entry point 'glProgramUniform2d'!
          Could not find required OpenGL entry point 'glProgramUniform3d'!
          Could not find required OpenGL entry point 'glProgramUniform4d'!
          Could not find required OpenGL entry point 'glProgramUniform1iv'!
          Could not find required OpenGL entry point 'glProgramUniform2iv'!
          Could not find required OpenGL entry point 'glProgramUniform3iv'!
          Could not find required OpenGL entry point 'glProgramUniform4iv'!
          Could not find required OpenGL entry point 'glProgramUniform1uiv'!
          Could not find required OpenGL entry point 'glProgramUniform2uiv'!
          Could not find required OpenGL entry point 'glProgramUniform3uiv'!
          Could not find required OpenGL entry point 'glProgramUniform4uiv'!
          Could not find required OpenGL entry point 'glProgramUniform1fv'!
          Could not find required OpenGL entry point 'glProgramUniform2fv'!
          Could not find required OpenGL entry point 'glProgramUniform3fv'!
          Could not find required OpenGL entry point 'glProgramUniform4fv'!
          Could not find required OpenGL entry point 'glProgramUniform1dv'!
          Could not find required OpenGL entry point 'glProgramUniform2dv'!
          Could not find required OpenGL entry point 'glProgramUniform3dv'!
          Could not find required OpenGL entry point 'glProgramUniform4dv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix2fv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix3fv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix4fv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix2dv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix3dv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix4dv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix2x3fv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix3x2fv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix2x4fv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix4x2fv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix3x4fv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix4x3fv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix2x3dv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix3x2dv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix2x4dv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix4x2dv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix3x4dv'!
          Could not find required OpenGL entry point 'glProgramUniformMatrix4x3dv'!
          Could not find required OpenGL entry point 'glValidateProgramPipeline'!
          Could not find required OpenGL entry point 'glGetProgramPipelineInfoLog'!
          Required OpenGL extension "GL_ARB_separate_shader_objects" is not supported.  Please update your OpenGL driver.
          Error: CheckGLExtensions():
          Required OpenGL extension "GL_ARB_separate_shader_objects" is not supported.  Please update your OpenGL driver.
          
          Attempting to create OpenGL context: v3.3 (Core profile)...success.
          Game removed: AppID 570 "Dota 2", ProcID 18788
          SOLUTION:
          http://askubuntu.com/a/501577

          Note: The solution fixed dota, but it fucked up some other games.
          Last edited by sindrom; 06-28-2015, 02:45 PM.

          Comment


          • #6
            Hi,

            When I run Reborn it just show:

            "CreateContext():
            Failed to create a OpenGL context."

            Quad 6400
            4GB ram

            Linux diver 3.16.0-49-generic #65~14.04.1-Ubuntu SMP Wed Sep 9 10:03:23 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux


            OpenGL vendor string: Intel Open Source Technology Center
            OpenGL renderer string: Mesa DRI Intel(R) G41
            OpenGL version string: 2.1 Mesa 11.1.0-devel (git-47e18a5 2015-09-16 trusty-oibaf-ppa)
            OpenGL shading language version string: 1.20
            OpenGL extensions:
            OpenGL ES profile version string: OpenGL ES 2.0 Mesa 11.1.0-devel (git-47e18a5 2015-09-16 trusty-oibaf-ppa)
            OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16
            OpenGL ES profile extensions:

            apt-get install xserver-xorg-video-intel {already cool}
            add-apt-repository ppaibaf/graphics-drivers {up mesa from 10.3.1 to 11.1}


            Please, there is any soul that could help me... I need Dota... please

            Comment


            • #7
              This is the screen trying to run reborn:

              "ExecSteamURL: "steam://open/downloads"
              Generating new string page texture 603: 64x256, total string texture memory is 1,18 MB
              Installing breakpad exception handler for appid(steam)/version(1440016726)
              Installing breakpad exception handler for appid(steam)/version(1440016726)
              Game update: AppID 570 "Dota 2", ProcID 3962, IP 0.0.0.0:0
              ERROR: ld.so: object '/home/nostra/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
              ERROR: ld.so: object '/home/nostra/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
              pid 3965 != 3964, skipping destruction (fork without exec?)
              ERROR: ld.so: object '/home/nostra/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
              ERROR: ld.so: object '/home/nostra/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
              Using breakpad crash handler
              Setting breakpad minidump AppID = 570
              Forcing breakpad minidump interfaces to load
              Looking up breakpad interfaces from steamclient
              Calling BreakpadMiniDumpSystemInit
              Looking up breakpad interfaces from steamclient
              Calling BreakpadMiniDumpSystemInit
              Steam_SetMinidumpSteamID: Caching Steam ID: 76561198091445368 [API loaded yes]
              Steam_SetMinidumpSteamID: Setting Steam ID: 76561198091445368
              Setting breakpad minidump AppID = 373300
              Failed to create an OpenGL context.
              Dongle firmware /home/nostra/.local/share/Steam/linux64/../controller_base/d0ggle.bin loaded, version 1435869091.
              Attempting to create OpenGL context: v3.3 (Core profile)...failed.
              Attempting to create OpenGL context: v3.1 (Core profile)...failed."

              Comment


              • #8
                SOLVED... Reborn minimum requirement is OpenGL 3

                Comment


                • #9
                  i have also error:
                  "Failed to create an OpenGL context.
                  Your graphics card must support at least OpenGL v3.1. "

                  my laptop specs:
                  OS: linux mint 17.3 cinnamon "Rosa"
                  Acer TravelMate-4740
                  4gb RAM
                  500 HDD
                  Core i3

                  my OpenGL:
                  OpenGL vendor string: Intel Open Source Technology Center
                  OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile
                  OpenGL version string: 2.1 Mesa 10.5.9
                  OpenGL shading language version string: 1.20
                  OpenGL extensions:

                  is there a way i can upgrade my OpenGL? or is it the graphics card? can u please help me with this problem...i want also to play dota in my laptop.
                  Last edited by awencheww; 05-28-2016, 02:03 AM.

                  Comment


                  • #10
                    Originally posted by awencheww View Post
                    i have also error:
                    "Failed to create an OpenGL context.
                    Your graphics card must support at least OpenGL v3.1. "

                    my laptop specs:
                    OS: linux mint 17.3 cinnamon "Rosa"
                    Acer TravelMate-4740
                    4gb RAM
                    500 HDD
                    Core i3

                    my OpenGL:
                    OpenGL vendor string: Intel Open Source Technology Center
                    OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile
                    OpenGL version string: 2.1 Mesa 10.5.9
                    OpenGL shading language version string: 1.20
                    OpenGL extensions:

                    is there a way i can upgrade my OpenGL? or is it the graphics card? can u please help me with this problem...i want also to play dota in my laptop.
                    It depends on your graphic card. If it is nvida or amd you should install propietary drivers. If it is intel, you might need a newer driver, because it seems that now you have open gl 4.3 available. You will have to google that.

                    Comment


                    • #11
                      I'm using Ubuntu 16.04 and it says Failed to Start Game (Missing Executable). I tried to solve but nothing works.

                      Comment

                      Working...
                      X