Results 1 to 3 of 3

Thread: Crash to desktop if clicking normal/ranked match on Tab menu...

  1. #1
    Basic Member
    Join Date
    Oct 2014
    Posts
    2

    Question Crash to desktop if clicking normal/ranked match on Tab menu...

    Alright guys, this one is gonna make your brain crumble.
    I started playing dota 2, two days ago. it was a fresh install etc, all good.
    Problem is, every time I click Normal match or ranked match within the "Play" tab, It crashes to desktop. no errors, nothing.
    If I queue with friends and THEY click it, I can join, play, and finish without any problems.

    I tried:
    Reinstalling (i even moved the install from HDD to SSD, so its no leftover files)
    Changing every single video setting, resolution etc
    Lowering refresh rate from 120 to 60hz

    Note:
    -Temperatures are always stable, CPU goes around 40-55 on load/gameplay, and GPU around 45-60 (celcius degrees)
    For some reason, the game load time increased from about 5 seconds to 30 seconds after reinstall, when it should be faster now that it is on SSD...???
    However, It doesnt eat my CPU nor my memory, so I dont see why that occurs...

    I did try to run with only 1 core (affinity in task manager), that resulted in bluescreen when clicking "play". first bluescreen ever on this pc.


    My pc:
    Intel i5-4670k
    GTX 760 GPU
    MSI Z87-G45 motherboard
    Kingston 8GB HyperX Beast DC DDR3-2400
    Windows 7 64bit
    Pc is about 6months old, and its only in dota2 problems occur ever, I play alot of CS:GO from steam aswell and I have no problems at all.


    edit: here is the dump file from the first crash after reinstall, I have newer ones too if wanted (after I did all the changes), but none of it has had any impact on the problem so I guess they are all the same...?
    https://www.dropbox.com/s/ehp4ymv1h4...tion.mdmp?dl=0
    Last edited by shaNk; 10-21-2014 at 06:21 AM.

  2. #2
    Basic Member aveyo's Avatar
    Join Date
    Aug 2012
    Location
    EU West
    Posts
    2,927
    Killer Ethernet: Kill Your Lag (And Crash To Desktop)
    You have Qualcomm Atheros Killer Network card - update from http://www.qca.qualcomm.com/resources/driverdownloads/ or from msi
    So the fix is to open Killer Network Manager from the system tray and:
    - click Applications, untick "Show running only", and change priority from high/very high to normal (value 3) for steam.exe and dota.exe
    - click Network and untick "Qualcomm Atheros Bandwidth Control"

    Note that I don't have this card so I'm not sure instructions are accurate enough.

    I will work on automating the fix of this killer network issue with just a batch file, for any pc/laptop. Will post on my guide when I have the time

  3. #3
    Basic Member
    Join Date
    Oct 2014
    Posts
    2
    You did it! Fixed it! Thank you so much! Never thought that the network card software would case a crash to desktop, I would assume lag issues instead so that was so uncalled for, today I learned.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •