Results 1 to 9 of 9

Thread: [Fixed] Sound at alt+tab

  1. #1
    Basic Member
    Join Date
    Nov 2012
    Posts
    6

    Unhappy [Fixed] Sound at alt+tab

    https://github.com/ValveSoftware/Dota-2/issues/710

    The problem is that when game is curtailed I I don't hear a gong sound about acceptance of game (search). Music, game sounds after the beginning everything works.

    My config

    Processor Information:
    Vendor: GenuineIntel
    Speed: 2501 Mhz
    4 logical processors
    2 physical processors
    HyperThreading: Supported
    FCMOV: Supported
    SSE2: Supported
    SSE3: Supported
    SSSE3: Supported
    SSE4a: Unsupported
    SSE41: Supported
    SSE42: Supported

    Network Information:
    Network Speed:

    Operating System Version:
    Ubuntu 13.04 (64 bit)
    Kernel Name: Linux
    Kernel Version: 3.8.0-29-generic
    X Server Vendor: The X.Org Foundation
    X Server Release: 11303000
    X Window Manager: Compiz
    Steam Runtime Version: steam-runtime-release-i386_2013-06-28

    Video Card:
    Driver: NVIDIA Corporation GeForce GT 555M/PCIe/SSE2

    Driver Version: 4.3.0 NVIDIA 325.15
    Desktop Color Depth: 24 bits per pixel
    Monitor Refresh Rate: 60 Hz
    VendorID: 0x10de
    DeviceID: 0xdce
    Number of Monitors: 1
    Number of Logical Video Cards: 2
    Primary Display Resolution: 1366 x 768
    Desktop Resolution: 1366 x 768
    Primary Display Size: 13,54" x 7,60" (15,51" diag)
    34,4cm x 19,3cm (39,4cm diag)
    Primary VRAM: 2048 MB

    Sound card:
    Audio device: Intel CougarPoint HDMI

    Memory:
    RAM: 7933 Mb

    Miscellaneous:
    UI Language: English
    LANG: ru_RU.UTF-8
    Microphone: Not set
    Total Hard Disk Space Available: 72995 Mb
    Largest Free Hard Disk Block: 42104 Mb

    Installed software:

    Recent Failure Reports:
    Sun Aug 18 16:45:00 2013 GMT: file ''/tmp/dumps/crash_20130818204452_1.dmp'', upload no: ''Failure when receiving data from the peer''
    Last edited by Xakep16; 08-18-2013 at 11:40 AM. Reason: add issues

  2. #2
    Basic Member
    Join Date
    Nov 2011
    Posts
    613
    Try this...
    It should be in the option screen @ Audio tab -
    "Sound while Alt-Tab"

    Let me know if this helps

  3. #3
    Basic Member
    Join Date
    Nov 2011
    Posts
    28
    I have the same problem with windows. You can fix it through changing your primary sound device. I always hear Dota on my headphones and music through my sound system. When the primary audio device(of my entire os) is set to my sound system I can change volume of my music with my keyboard but every time I'm alt tapped away from Dota (browsing etc, dota is in the background) the Dota game is ready sound(the dong) isn't coming through my headphones but from the sound system. When I'm playing Dota everything is fine because I choose my headphones as audio device in the dota audio settings and I enabled sound when alt taped.

    So you can fix it by choosing your headphones as primary audio device (in your os). Then you will be able to hear the dong even when you are alt taped and in your browser. That's the way it works for me with windows 8 as os.
    Valve could fix it that we always hear the sound from the device we choose in Dota even when Dota is in the background.

  4. #4
    Basic Member
    Join Date
    Nov 2012
    Posts
    6
    Quote Originally Posted by MikeyBooT12 View Post
    Try this...
    It should be in the option screen @ Audio tab -
    "Sound while Alt-Tab"

    Let me know if this helps
    It at me is included. When game is contracted I hear game sounds (music, fight. ) . I hear music in the main menu) all but the button of acceptance of game.

  5. #5
    Basic Member
    Join Date
    Nov 2012
    Posts
    6
    Quote Originally Posted by BonzenPaule View Post
    I have the same problem with windows. You can fix it through changing your primary sound device. I always hear Dota on my headphones and music through my sound system. When the primary audio device(of my entire os) is set to my sound system I can change volume of my music with my keyboard but every time I'm alt tapped away from Dota (browsing etc, dota is in the background) the Dota game is ready sound(the dong) isn't coming through my headphones but from the sound system. When I'm playing Dota everything is fine because I choose my headphones as audio device in the dota audio settings and I enabled sound when alt taped.

    So you can fix it by choosing your headphones as primary audio device (in your os). Then you will be able to hear the dong even when you are alt taped and in your browser. That's the way it works for me with windows 8 as os.
    Valve could fix it that we always hear the sound from the device we choose in Dota even when Dota is in the background.
    Problem in that I can't select from Ubuntu an audio system. List place I see Windows default sound. I tested on earphones and columns.
    Concerning windows 8, a sound of a gong I hear in 90% cases Even if music is included.

  6. #6
    Basic Member
    Join Date
    Jul 2013
    Posts
    109
    Yes, game ready sound is broken for everybody on linux. It's been reported multiple times in this forum and on github. See bug #64.
    Also, the sound device control is currently just a placeholder, it doesn't do anything. That's bug #12.
    Last edited by hirsute; 08-18-2013 at 03:31 PM.

  7. #7
    Basic Member
    Join Date
    Nov 2011
    Posts
    613
    Oh Linux, Yes it is the sound system, do you have multiple ports for sounds? a monitor with speakers or something?

  8. #8
    Basic Member
    Join Date
    Jul 2013
    Posts
    109
    We are in the linux feedback subforum. OP is using a linux system. The linux (and mac os) build of dota2 does not play the game ready sound when it doesn't have focus. Valve is aware of the issue. A Valve dev told us it will be fixed it in the next update.

  9. #9
    Basic Member
    Join Date
    Nov 2012
    Posts
    6
    thx) valve fix this bag))

    Now the user will always hear a distinctive sound when it finds a game. Added notification that the game for the desktop. [Linux]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •