I rebound the voice chat straight away so that my conversation out of game doesn't pass over into game (VoIP clients).

I use "T" now, however i've found that now both "T" and "mouse4" are both activating push to talk in game.

I just checked the config.cfg in dota/cfg and surely enough both are bound to +voicerecord.

So, the config isn't being altered properly by the changes made in the game options.

(Search didn't reveal similar posting).

Thanks