I have been getting a bug with Medusa's Model, specifically her head piece. I have loaded about 7 other models and none of them have any problems with their premade animations. I have tried deleting the animation set and model, and reloading her again, loading her model on a new movie clip, etc. And nothing seems to work, in every animation i load her head snakes are pushed stiff back, even if in the animation preview they move around properly. I tried loading each 1 by 1 and none help.

Other models i have loaded into my project work properly, from running, to idle, to death animations. Here is a picture of how her head snakes look all the time.


The way im loading her model is:

1.Clicking into the + button.
2.Create animation set for new model
3.Type medusa on the filter bar.
4.Then load up: medusa, medusa_arms, medusa_arrow, medusa_bow, medusa_tail, medusa_torso, medusa_veil.
5.Then i parent the main medusa piece with each of the other parts and load the animation into medusa.vmdl.

It seems to work for every other hero i have tried, but i cant get it to work with her. There might be something im doing wrong that i cant see. If anyone can help me on this ill appreciate it. I also cant seem to click on any joints there to animate the snakes manually. I would be at least satisfied if i could get the snakes to a more natural position.