The lighting acts weird when you disable the shadows despite to what we have in SFM1.
It works fine on GlobaLitSimple models though (see the screenshot below).

Steps to reproduce the bug:
1 Add any model using CustomHero shader in the scene
2 create a light and place it behind a model
3 disable shadows on the light
Result: light goes through the model

A quick demonstration, (it happens only to the hero model, rock receives the light just fine)
HY7n4Kr-9aE.jpg