Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13

Thread: help my model editor keep crashing

  1. #11
    Valve Developer
    Join Date
    Aug 2014
    Thanks for helping out with this. We were in fact missing the install of the Microsoft Visual C++ Redistributable package. It should now install this for you automatically the next time you run if you don't have it installed already.

  2. #12
    Basic Member NB.'s Avatar
    Join Date
    Apr 2012
    Sorry for the late reply, i have been away from modding last few days unable to report back.
    Problem has been solved thanks to the latest patch download as mentioned.

    Cant touch this :-j

  3. #13
    Basic Member
    Join Date
    Jun 2012

    Quote Originally Posted by karlw View Post
    Thanks for trying that. There are a few other files that model editor depends on that the other tools don't, if you are missing any of these, that could be the problem as well.

    ...\Steam\SteamApps\common\dota 2 beta\game\bin\win64\shiboken-python2.7.dll
    ...\Steam\SteamApps\common\dota 2 beta\game\bin\win64\python27.dll
    ...\Steam\SteamApps\common\dota 2 beta\game\bin\win64\QtOpenGL4.dll

    These in turn depend on some common Windows dlls:
    Sorry to bring this post back, thought I will post/share my fix with same error but different situation
    my problem is that I got Microsoft Visual C++2010 x86 Redistributable and Microsoft Visual C++2010 x64 Redistributable with version 10.0.40219
    knowing my version is incorrect, I uninstall them and download the link from @malloc
    so now I got version 10.0.30319 for both x86 and x64, but I still got same error when try to open the model editor
    then I went to C:\Windows\System32\, found out the msvcr100.dll and msvcp100.dll are still version 10.0.40219 after uninstall x64 Redistributable 10.0.40219 and reinstall x64 Redistributable 10.0.30319
    therefore I moved those 2 files to desktop, uninstall and reinstall Microsoft Visual C++2010 x64 Redistributable(10.0.30319), check back to C:\Windows\System32\, both msvcr100.dll and msvcp100.dll are version 10.0.30319 now and I can finally open model editor

    so if you got same problem as I am, hope this post helps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts