Results 1 to 2 of 2

Thread: Unable to play on Linux

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Basic Member
    Join Date
    Sep 2015

    Unable to play on Linux


    I have a Debian 8.0 (Jessie) system with Steam and Dota2 installed. I play Dota2 on this for about 8 months and Dota2 Reborn since the begining without any problem. After the last update, in which the option to choose between Dota2 and Reborn was removed and you can only play Reborn now the problem started.

    I can ented the game normally and find matches. But when I choose a hero, the problem begins to show. The hero sprite does not appear although the game reacts as if I indeed selected the hero. The game doesn't crashes or freezes, it keeps working just as fine besides the fact that the hero is not dipslayed (with some glitches on the screen). After the pick phase, when I press the button to enter the match, it enters but the map is not displayed. It keeps displaying the screen to select the heroes but the hud, the chat and health bars, the mouse pointer and select boxes (those green ones to select multiple units) are displayed. Even though this things are displayed, they also have a "Solitary-like" cascate effect when they move. Chat message also do not disappear. Check out the screenshots below:

    I've tried closing and opening the game a few times and it still not work.

    The problem happens in any kind of matchmaking including bots.

    Another problem that stated after this update is that the sound stopped working as well. Don't know if it's related to this problem.

    Can I provide any other useful information to describe the problem?

  2. #2
    Basic Member
    Join Date
    May 2016
    Hi! Jessie - the stable distr. by GNU/Linux. This use very old libraries such as Intel DRM and DRI.
    show me pls command in console ":~# lspci

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts