Results 1 to 4 of 4

Thread: 10+ bugs of using npc_abilities_override.txt. hope you can fix them finally

  1. #1
    Basic Member
    Join Date
    Nov 2014
    Posts
    71

    Exclamation 10+ bugs of using npc_abilities_override.txt. hope you can fix them finally

    I really don't wanna use 3rd lib or spend much time writing myself. Valve pls fix them!

    Legion Commander can't duel an enemy 2000 away or, stops instantly
    Huskar can't life break an enemy 1400 away, or stops instantly
    Tusk ult and scepter kick range can't be changed
    Io can't tether an ally 1800 away or leave after tether, or break instantly
    Earth spirit if smashes a boulder to farther than 2000 away, there must be a boulder 200 near yourself and a boulder 200 near target to ensure the nearby one be smashed
    Earth spirit if has a boulder 200 near him, he can't target "smash boulder" on an ally or an enemy
    Earthshaker fissure length can't be too long, or there will be a lag (50ms if set to 5000 and 200ms if set to 20000)
    Pudge strength acquired and Silencer intelligence acquired by kill, the radius of which can't be changed
    Bloodseeker rupture minimum distance to ignore damage can't be changed
    Force staff push speed can't be changed
    Visage Familiar and beastmaster summons attributes can't be changed, as well as tusk, undying, pugna summons hp
    Viper corrosive skin proc range can't be changed
    Cyclone scepter target type can't be changed
    Beastmaster summons duration can't be changed
    Last edited by litianren01; 01-05-2017 at 10:13 PM.

  2. #2
    Basic Member
    Join Date
    Jan 2012
    Posts
    144
    How are those 'bugs'? It all works exactly as intended. You can always do these abilities yourself or use SpellLibrary and change whatever you want..

  3. #3
    Basic Member
    Join Date
    Nov 2014
    Posts
    71
    Quote Originally Posted by DoctorGester View Post
    How are those 'bugs'? It all works exactly as intended. You can always do these abilities yourself or use SpellLibrary and change whatever you want..
    I know. But my mod is extremely dota-like and I want to stick to the origin files, or it will be time-wasting to rewrite descriptions, and maintain when dota version updates if stick to 3rd lib. SpellLibrary also doesn't provide scepter upgraded skills. I know Valve has much work to do even doesn't have time to reply almost any feedbacks. But please, just expose some more arguments, and everything will be better. I hope one day it can come true.
    Last edited by litianren01; 11-14-2015 at 10:41 PM.

  4. #4
    Basic Member
    Join Date
    Jul 2015
    Posts
    10
    Overriding "ItemPermanent" does not work for most items either.
    http://dev.dota2.com/showthread.php?...31#post1273931

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •