Results 1 to 10 of 10

Thread: Sound cuts out during gameplay

  1. #1
    Basic Member
    Join Date
    Apr 2016
    Posts
    7

    Sound cuts out during gameplay

    About a month or so ago (around the time of that patch to help with lag and packet loss) I noticed that sound would begin cutting out during gameplay. I don't remember if I had changed any settings or not with steam or dota, I really don't think I did. The problem begins when I'm about halfway through a match, and sometimes I can make it through one full match without losing any sound. Never more than 2-3 now though. At some point in game, a spell or certain spawn, ping, or voice will not be heard. Shortly after that it is as though all sound starts to drop from gameplay. Sometimes pings or respawn or certain character voice noises will remain for a short period of time but eventually 1 by 1 all sound drops until eventually there is literally no sound at all in-game. When match is over and I come back to the main screen, music starts playing again as if nothing had happened at all. Please someone respond because I'm having to restart steam after every single match I play just to ensure I have sound for the majority of the next game I am going to play. This is so frustrating... I don't know what to do or what is causing this.

  2. #2
    Basic Member aveyo's Avatar
    Join Date
    Aug 2012
    Location
    EU West
    Posts
    2,922
    Dota 2 - Settings - Audio - uncheck High Quality Audio.
    It's better to force this in an autoexec.cfg:
    Code:
    dsp_slow_cpu 1;
    snd_autodetect_latency 0;
    snd_mixahead 0.1;
    And you might need to experiment with Streamlined Push to Talk (voice_always_sample_mic) on or off.

  3. #3
    Basic Member
    Join Date
    Apr 2016
    Posts
    7
    I think I did toy around with some of that around that time. How do I access this or where do I find this .cfg??

  4. #4
    Basic Member aveyo's Avatar
    Join Date
    Aug 2012
    Location
    EU West
    Posts
    2,922
    You use google like everybody else.

    It's just a text file where you add the above code lines.
    Correct name is autoexec.cfg
    Check it's like that and not autoexec.cfg.txt (disable Hide extensions for known file types in Explorer).
    Place the file in \steamapps\common\dota 2 beta\game\dota\cfg\

    In case it's not auto-executed, open the console in-game and enter exec autoexec.cfg

  5. #5
    Basic Member
    Join Date
    Apr 2016
    Posts
    7
    I was in process X) ty tho

  6. #6
    Basic Member
    Join Date
    Apr 2016
    Posts
    7
    Second question, I found the dsp_slow_cpu and changed it to 1, it was at 0, I did not see the snd_detect_latency.. Should I add this?
    Last edited by 420ms; 04-06-2016 at 10:08 AM.

  7. #7
    Basic Member
    Join Date
    Apr 2016
    Posts
    7
    I just added that line, I am going to try game and see how it goes, will let u know ty for your help sir!

  8. #8

  9. #9
    Basic Member
    Join Date
    Apr 2016
    Posts
    7
    I changed/added the 3 text lines above, 1 game fine, 2nd game lost sound again after about 10 mins, going to attempt using the voice sampling lines bc I did not see them in my cnfg file and it was checked on box in client. Will let u know how it turns out.

  10. #10
    Basic Member
    Join Date
    Apr 2016
    Posts
    1
    OP I've got the exact same issue - it's killing me. Did you find any luck with those cfg settings?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •