Page 3 of 3 FirstFirst 1 2 3
Results 21 to 28 of 28

Thread: Bug after the newest update (17-May-16)

  1. #21
    Downloaded newest update... Loaded game for the first time... clicked on the compendium link.... cant upload dota now after clicking the link.... Please help. Was able to play this game this morning.

  2. #22
    Basic Member
    Join Date
    Apr 2016
    Posts
    18
    Win 7 ultimate here. Crash after logo. Tried verifying cache. Didn't work. Uninstall/Reinstall. Doesn't work either.

    Game literally unplayable.

  3. #23
    Im having the same problem... logo comes up... then dota 2 closes. The cursor changes for a second.

    Quote Originally Posted by UnfairBot View Post
    Win 7 ultimate here. Crash after logo. Tried verifying cache. Didn't work. Uninstall/Reinstall. Doesn't work either.

    Game literally unplayable.

  4. #24
    Basic Member
    Join Date
    May 2016
    Posts
    2
    Game is working in offline mode though... don't know what good that does, but its something.

  5. #25
    I am a Windows guy and im having the same problem >.<

  6. #26
    I could start one game, but then I got to update again and it started crashing all over again.

  7. #27
    Basic Member
    Join Date
    May 2016
    Posts
    7
    The newest update fix the problem for me. Thanks

  8. #28
    Basic Member
    Join Date
    Apr 2016
    Posts
    12
    you're wasting your time .. no one looks at these posts !

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •