Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13

Thread: [BUG] Volumetric light with texture causes crash

  1. #1
    Basic Member
    Join Date
    Apr 2013
    Posts
    22

    Exclamation [BUG] Volumetric light with texture causes crash

    Hi
    After last dota2 update volumetric lights with gobo texture causes sfm(dota2) crash. For example I used "web_02" texture in my project.
    Hope it will be fixed soon, because contest
    Thank you.

  2. #2
    Basic Member
    Join Date
    Jul 2015
    Posts
    132
    Mine seems to work for me using the same things you described: BNL3GsD.jpg

    Vconsole has nothing in it for me when I do this either.

  3. #3
    Basic Member
    Join Date
    Apr 2013
    Posts
    22
    Try to disable-enable volumetric after accepting texture.

  4. #4

  5. #5
    Basic Member
    Join Date
    Jul 2015
    Posts
    132
    You still need to post the vconsole log if you want any help from devs or other users along with your system information whcih can be found under help -> system information in the Steam client.

  6. #6
    Basic Member
    Join Date
    Apr 2013
    Posts
    22
    Vconsole has nothing special.
    Disconnected From 'Localhost:29000'
    Connecting To 'Localhost:29000'
    Also recorded short video with my steps:
    https://youtu.be/DJPy1a1obv0
    Processor Information:
    CPU Vendor: GenuineIntel
    CPU Family: 0x6
    CPU Model: 0x3c
    CPU Stepping: 0x3
    CPU Type: 0x0
    Speed: 3500 Mhz
    8 logical processors
    4 physical processors
    HyperThreading: Supported
    FCMOV: Supported
    SSE2: Supported
    SSE3: Supported
    SSSE3: Supported
    SSE4a: Unsupported
    SSE41: Supported
    SSE42: Supported
    AES: Supported
    AVX: Supported
    CMPXCHG16B: Supported
    LAHF/SAHF: Supported
    PrefetchW: Supported


    Operating System Version:
    Windows 7 (64 bit)
    NTFS: Supported
    Crypto Provider Codes: Supported 311 0x0 0x0 0x0

    Video Card:
    Driver: NVIDIA GeForce GTX 770

    DirectX Driver Name: nvd3dum.dll
    Driver Version: 10.18.13.6822
    DirectX Driver Version: 10.18.13.6822
    Driver Date: 19 May 2016
    OpenGL Version: 4.5
    Desktop Color Depth: 32 bits per pixel
    Monitor Refresh Rate: 60 Hz
    DirectX Card: NVIDIA GeForce GTX 770
    VendorID: 0x10de
    DeviceID: 0x1184
    Revision: 0xa1
    Number of Monitors: 1
    Number of Logical Video Cards: 1
    No SLI or Crossfire Detected
    Primary Display Resolution: 1920 x 1080
    Desktop Resolution: 1920 x 1080
    Primary Display Size: 26.65" x 15.00" (30.55" diag)
    67.7cm x 38.1cm (77.6cm diag)
    Primary Bus: PCI Express 16x
    Primary VRAM: 2047 MB
    Supported MSAA Modes: 2x 4x 8x

    Sound card:
    Audio device: ???????? (Realtek High Definiti

    Memory:
    RAM: 16314 Mb

  7. #7

  8. #8
    Basic Member
    Join Date
    Jul 2015
    Posts
    132
    I'm only able to reproduce it by adding the texture first, then volumetrics, the other way around works for me.

    Steps to reproduce:

    1. Add light to scene.

    2. Add gobo light texture to web_02

    3. Enable volumetrics on light.


    Steps for it working:

    1. Add light to scene.

    2. Enable volumetrics on light.

    3. Add gobo light texture to web_02.

    4. Add jitter to the light.

    Produced result of working (July 5th 2016) 8JXOkx5.jpg

  9. #9
    Valve Developer
    Join Date
    Jun 2015
    Posts
    24
    This is fixed, but slipped through the cracks for today's update. Until the next update, you should be able to disable software command lists to avoid crashing.
    Type this on your console to disable software command lists:
    r_dx11_software_cmd_lists 0

  10. #10
    Basic Member
    Join Date
    Jul 2015
    Posts
    132
    Quote Originally Posted by joe_prime View Post
    This is fixed, but slipped through the cracks for today's update. Until the next update, you should be able to disable software command lists to avoid crashing.
    Type this on your console to disable software command lists:
    r_dx11_software_cmd_lists 0
    Works for me on vulkan with this command. Not sure if the console output is worth anything:

    [ ]: ] r_dx11_software_cmd_lists 0
    [ SteamDatagramClient ]: Failed to communicate with routing cluster 'lax'.
    [ SteamDatagramClient ]: Communications with routing cluster 'lax' established.
    [ SteamDatagramClient ]: Failed to communicate with routing cluster 'bom'.
    [ General ]: Ping measurement complete.
    [ W General ]: CSFMParticleSystemQuery::GetCollisionGroupFromName not yet implemented!
    [ Developer ]: Unserialize c:\program files (x86)\steam\steamapps\common\dota 2 beta\game\dota_addons\sfmcontest2\elements\session s\supportsclub.dmx took 0.622 seconds
    [ W SchemaSystemUtils ]: WARNING: Schema upconversion occuring for large data (1310kb): maps/dota_sfm/worldnodes/node000.vwnod
    [ W General ]: c:\buildslave\source2_dota_rel_win64\build\src\ren dersystem\texturebase.cpp(2089):ResourceHandleToDa ta( ) failed! Falling back to error texture!
    [ W General ]: c:\buildslave\source2_dota_rel_win64\build\src\ren dersystem\texturebase.cpp(2089):ResourceHandleToDa ta( ) failed! Falling back to error texture!
    [ ]: VConsole Rejecting Message: 'PHRA'
    [ W General ]: CSFMParticleSystemQuery::GetWindVelocityAtLocation not yet implemented!
    [ W General ]: CSFMParticleSystemQuery::GetAnimDecodeRealTime not yet implemented!
    [ W ToneMapping ]: CTonemapSystem::GenerateRendererData ran out of buckets!!
    [ W ToneMapping ]: CTonemapRenderer is trying to render with an invalid occlusion query handle. Are we rendering while the screen isn't visible? Look for a previous warning saying we ran out of buckets.
    [ W ToneMapping ]: CTonemapSystem::GenerateRendererData ran out of buckets!!
    [ W ToneMapping ]: CTonemapRenderer is trying to render with an invalid occlusion query handle. Are we rendering while the screen isn't visible? Look for a previous warning saying we ran out of buckets.
    [ W ToneMapping ]: CTonemapSystem::GenerateRendererData ran out of buckets!!
    [ W ToneMapping ]: CTonemapRenderer is trying to render with an invalid occlusion query handle. Are we rendering while the screen isn't visible? Look for a previous warning saying we ran out of buckets.
    [ W ToneMapping ]: CTonemapSystem::GenerateRendererData ran out of buckets!!
    [ W ToneMapping ]: CTonemapRenderer is trying to render with an invalid occlusion query handle. Are we rendering while the screen isn't visible? Look for a previous warning saying we ran out of buckets.
    [ W ToneMapping ]: CTonemapSystem::GenerateRendererData ran out of buckets!!
    [ W ToneMapping ]: CTonemapRenderer is trying to render with an invalid occlusion query handle. Are we rendering while the screen isn't visible? Look for a previous warning saying we ran out of buckets.
    [ W RenderSystem ]: Texture missing shader resource view - returning error texture in CTextureManagerDx11::GetResourceView

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •