Results 1 to 5 of 5

Thread: [BUG]Tools unstable after latest NVIDIA update!

  1. #1
    Basic Member
    Join Date
    Sep 2013
    Posts
    80

    Exclamation [BUG]Tools unstable after latest NVIDIA update!

    After the 372.90 NVIDIA driver update the particle effect tools crash when you try to resize a window/UI element or change a parameter when running on Vulkan. A workaround to that it to launch with -dx9, but that makes the model editor crash when you try to resize it or any of its UI elements or try to save the file.

    This makes working on FX and models quite frustrating as you have to keep restarting the game and changing from dx9 to vulkan.

    My specs:
    Clevo Laptop P370SM (U40)
    Intel i7-4700MQ 2.40GHz
    4x 8GB DDR3 Crucial Technology PC3-12800 (800 MHz)
    2x NVIDIA GeForce GTX 765M

  2. #2
    Basic Member
    Join Date
    Sep 2013
    Posts
    80
    Update: Since the patch today [October 3rd, 2016] it is now impossible to edit attachment points or do anything with the model editor as it just crashes regardless of what mode I launch the game in. -dx9 -dx11 -vulkan It crashes on all of them!

  3. #3
    Basic Member Toyoka's Avatar
    Join Date
    Oct 2013
    Location
    Current position co-ordinates non-tracable. Unknown space.
    Posts
    833
    You shouldn't be launching the tools with any launch option video modes. They are known to be buggy especially with tools mode; the preview panels don't always render properly in (IIRC) dx9/dx10/dx11 and as you have experienced, the tools will crash consistently.

  4. #4
    Basic Member
    Join Date
    Sep 2013
    Posts
    80
    @Toyoka, dude what's up with you always replaying to all my technical posts (especially the ones aimed at Valve)? Sorry man, but most of your input so far hasn't been very helpful and often only distracts from the main topic.

    If you didn't notice from the post the tools crash regardless of whether or not I have any launch option on.

    Also what's your logic behind not using launch commands again, because it makes no sense? -dx9 -dx11 -vulkan -gl are all launch options for what renderer you want to use. Some of the tools are stable on ones and not on others. If you don't have any specified, it will launch with whatever your default is(dx9/dx11 or vulkan). The tools were running fine with no launch options until the latest NVIDIA update so I changed the renderer when I had to use a different tool, depending on what ran stable on what. Then the latest dota patch made all the tools unstable on dx9, dx11 and vulkan. As I found out through testing yesterday running the tools with -gl works! They are running stable on openGL. Performance isn't the best, but at least the tools work.
    Last edited by Abysswalker; 10-04-2016 at 10:14 AM.

  5. #5
    Basic Member MaxOfS2D's Avatar
    Join Date
    Jun 2015
    Location
    France
    Posts
    142
    Quote Originally Posted by Toyoka View Post
    You shouldn't be launching the tools with any launch option video modes. They are known to be buggy especially with tools mode; the preview panels don't always render properly in (IIRC) dx9/dx10/dx11 and as you have experienced, the tools will crash consistently.
    My tools have always had -d3d11 in their automatically-generated command line... so I figure that's what they require (especially for SFM2)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •