Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15

Thread: FPS drops in Dota 2 after update 6.88e

  1. #1
    Basic Member
    Join Date
    Oct 2016
    Posts
    5

    FPS drops in Dota 2 after update 6.88e

    I have fps drops these few days after the update.

    I have tried updating my drivers and lowering the graphics of the game(which hurts my eyes).

    Computer specs:ASUS brand laptop
    Cpu: intel core i7-4710hq @ 2.50ghz
    Ram:8gb
    Gpu:Nvidia Gtx 850m
    Windows 10 Home x64

    PLS TELL ME IF YOU HAVE A SOLUTION AND IF YOU ARE ALSO HAVING THE SAME PROBLEM.

  2. #2
    Basic Member
    Join Date
    Sep 2011
    Posts
    791
    What are your FPS drops? 10 FPS or 50 FPS? What amount are we talking about here.

    There was recently an Anniversary update for Windows 10 - if you haven't disabled Xbox DVR, it may be the root of your issue.

  3. #3
    Basic Member
    Join Date
    Oct 2016
    Posts
    5
    I tried disabling the Xbox dvr and updated windows. But still nothing has changed. PS my fps is currently around 30 to 20 fps. Any other solution?

  4. #4
    Basic Member aveyo's Avatar
    Join Date
    Aug 2012
    Location
    EU West
    Posts
    2,927
    There has been a performance regression in the last patch, specially under Exclusive Fullscreen mode, but it can't be so low for your hardware.

    You probably are not using the Nvidia GPU - check your Nvidia Control Panel, and force it as default for Dota 2 profile (and if that does not work, Globally)
    Note that you might have 2x dota2.exe profiles, one for 32bit, one for 64bit - do it for both.



    Then go to your Dota 2 installation folder \steamapps\common\dota 2 beta\game\dota\cfg\ and simply delete video.txt to force hardware detection.
    (or you could add launch options: -autoconfig then launch Dota 2 once, close it, and remove -autoconfig from launch options)

  5. #5
    Basic Member
    Join Date
    Oct 2012
    Posts
    32
    I played today after a week and after the last patch and I used to get 60 fps with maxed video settings except ultra shadows and 90% texture. But now every 10 seconds my fps drops to 30 for a few seconds and it happens right from the start. I was getting smooth 60 fps before the update and Ive configured the nvidia settings for dota.
    Lenovo Y50
    Processor Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz, 2501 Mhz, 4 Core(s), 8 Logical Processor(s)
    OS Name Microsoft Windows 10 Home Single Language
    Installed Physical Memory (RAM) 8.00 GB
    GPU 1 NVIDIA GeForce GTX 960M
    GPU 2 Intel(R) HD Graphics 4600

  6. #6
    Basic Member
    Join Date
    Dec 2011
    Posts
    21
    So I was playing a bot game today with Morphling and I had the same issue as you guys, FPS from steady 60 went down to 45 and at random to 10 then again increasing to 30-35 after a while. Any modifications to the video settings didn't even affect the framerate at all. What I found really strange though was that every time I cast Adaptive Strike, the fps would jump back to 60 for around 5 seconds, then drop again to 10 or 30-35. I should note that the game started with 60 fps and around 10-15 mins into the game, those fps problems started to appear. Now I'm not sure if it's the latest patch (Fall Battle Pass update) or the 6.88e that's causing this, but nevertheless, I hope it gets fixed.
    PC configuration:
    Intel Core i7 -2660k
    OS Microsoft Windows 10 Pro
    Installed Physical Memory (RAM) 8.00 GB
    Graphics Card: Gigabyte Nvidia GTX 970 G1 Gaming

  7. #7
    Basic Member
    Join Date
    Oct 2016
    Posts
    5
    Guys I tried everything and it still has the problem.

  8. #8
    Basic Member
    Join Date
    Sep 2011
    Posts
    791
    Quote Originally Posted by Stratos1986 View Post
    So I was playing a bot game today with Morphling and I had the same issue as you guys, FPS from steady 60 went down to 45 and at random to 10 then again increasing to 30-35 after a while. Any modifications to the video settings didn't even affect the framerate at all. What I found really strange though was that every time I cast Adaptive Strike, the fps would jump back to 60 for around 5 seconds, then drop again to 10 or 30-35. I should note that the game started with 60 fps and around 10-15 mins into the game, those fps problems started to appear. Now I'm not sure if it's the latest patch (Fall Battle Pass update) or the 6.88e that's causing this, but nevertheless, I hope it gets fixed.
    PC configuration:
    Intel Core i7 -2660k
    OS Microsoft Windows 10 Pro
    Installed Physical Memory (RAM) 8.00 GB
    Graphics Card: Gigabyte Nvidia GTX 970 G1 Gaming
    Considering I run an i5-2500k with a GTX 970 (very similar to yours) - but Windows 7, it's very clear that it's either a user problem (one of your installed programs, drivers, using your iGPU instead of dedicated GPU) or Windows 10 issue.

    Have you removed XBOX DVR?

  9. #9
    Basic Member
    Join Date
    Oct 2016
    Posts
    5
    Quote Originally Posted by Gozuu View Post
    Considering I run an i5-2500k with a GTX 970 (very similar to yours) - but Windows 7, it's very clear that it's either a user problem (one of your installed programs, drivers, using your iGPU instead of dedicated GPU) or Windows 10 issue.

    Have you removed XBOX DVR?
    I have already disbled Xbox dvr. The wierd thing is that I can play Overwatch with smooth 60 to 70 fps but not the same for Dota 2.

  10. #10
    Basic Member
    Join Date
    Sep 2011
    Posts
    791
    Quote Originally Posted by Uncany View Post
    I have already disbled Xbox dvr. The wierd thing is that I can play Overwatch with smooth 60 to 70 fps but not the same for Dota 2.
    I'm getting 130-150 FPS with most settings on High/Ultra in Overwatch, so I don't understand why you would only get 60-70 FPS?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •