Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13

Thread: Anyone else get error with 'GetActualDamage' on ally creep after update ?

  1. #11
    Quote Originally Posted by Cornbane View Post
    It's not hard to make the names, it's hard to make the names without then being too long. XD

    Calling it CalculateHowMuchDamageWouldBeTakenAfterReductions( int Damage, int DamageType) would get the message across, but it takes up so much space.
    Read:

    However, I see the problem that it is hard to find a good name for the function when it is unit based.

  2. #12
    Basic Member
    Join Date
    Dec 2016
    Posts
    731
    CalcRawDamage() and CalcResistAdjDamage() not too long. Also length doesn't really matter really. Compilers mangle it anyways.

  3. #13
    Quote Originally Posted by nostrademous View Post
    CalcRawDamage() and CalcResistAdjDamage() not too long. Also length doesn't really matter really. Compilers mangle it anyways.
    These two suggestions have the same issue as GetAcutalDamage(). Also long names matter for the programmers and make the code look ugly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •