Results 1 to 5 of 5

Thread: 'getfenv' (a nil value)

  1. #1
    Basic Member
    Join Date
    May 2014
    Posts
    270

    'getfenv' (a nil value)

    What is this mean? I got that from the dump file after my game crash. My game was so lag at that time before it crashed.
    Code:
    8597(8289.025349):  Failed to run script 'C:\Program Files (x86)\Steam\steamapps\workshop\content\570\837040016\ability_item_usage_generic.lua'!
    8596(8289.025332):  Script Runtime Error: ...hop\content\570\837040016\ability_item_usage_generic.lua:1: attempt to call global 'getfenv' (a nil value)
    stack traceback:
    	...hop\content\570\837040016\ability_item_usage_generic.lua:1: in main chunk
    8595(8289.024129):  Failed to run script 'C:\Program Files (x86)\Steam\steamapps\workshop\content\570\837040016\item_purchase_generic.lua'!
    8594(8289.024106):  Script Runtime Error: ...workshop\content\570\837040016\item_purchase_generic.lua:8: attempt to call global 'GetScriptDirectory' (a nil value)
    stack traceback:
    	...workshop\content\570\837040016\item_purchase_generic.lua:8: in main chunk
    I got another error
    Code:
    3036(7177.492630):  Failed to run script 'C:\Program Files (x86)\Steam\steamapps\workshop\content\570\837040016\ability_item_usage_naga_siren.lua'!
    3035(7177.492589):  Script Runtime Error: ...\content\570\837040016\ability_item_usage_naga_siren.lua:1: attempt to call global 'GetScriptDirectory' (a nil value)
    stack traceback:
    	...\content\570\837040016\ability_item_usage_naga_siren.lua:1: in main chunk
    Last edited by arz_on4dt; 02-10-2017 at 10:37 AM.

  2. #2
    Basic Member
    Join Date
    Dec 2016
    Posts
    731
    It means the script failed to load the global environment you have created many of the modules within.

  3. #3
    Basic Member
    Join Date
    May 2014
    Posts
    270
    Quote Originally Posted by nostrademous View Post
    It means the script failed to load the global environment you have created many of the modules within.
    What cause that? Is it because my script was so bad?

  4. #4
    Basic Member
    Join Date
    Dec 2016
    Posts
    731
    Never seen it before... sounds like a Steam/Valve hiccup. Is it reproducible?

    Also... is it 'getfenv' in your file? It should be 'getfenv()'

  5. #5
    Basic Member
    Join Date
    May 2014
    Posts
    270
    Quote Originally Posted by nostrademous View Post
    Never seen it before... sounds like a Steam/Valve hiccup. Is it reproducible?

    Also... is it 'getfenv' in your file? It should be 'getfenv()'
    It is 'getfenv()'. I got that crash after 4 games without any crash + 1 last game that have that crash around 20+ minutes mark. And that last game was so lag even though I only use host_timescale 1 (normal speed).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •