Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17

Thread: Stuck Establishing Connection. 24 Hour Ban WTF

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Angry Stuck Establishing Connection. 24 Hour Ban WTF

    I seriously don't know what's up with this. I just made an account because I got a 24h ban for accepting a game and not getting to load it because I never got to connect to the gameserver (Japan) multiple times. I get stuck on 'Establishing Connection' even though my internet is stable. This has never happened to me before but has happened today and yesterday.

  2. #2
    Basic Member
    Join Date
    Jul 2017
    Posts
    5
    Same thing happened to me on South American Servers. I accepted the queue, stuck on Connecting, then banned. It's not consistent though, I played couple games in between. But this has been happening in the last week, haven't seen this before.

    I'm not abusing the system or anything. I have over 1.5k games over multiple years and only 6 abandons which mostly are due to random connection losses and I usually still try-hard finish the game even if it's scored as loss for me.

    This feels somewhat unjust. I understand why the system is in place, but 24h seems a lot and especially when it's probably due to a bug or something. My network connection is fine.

  3. #3
    Basic Member
    Join Date
    Jul 2017
    Posts
    5
    Also to contribute something more than this vague bug report, here's another thing:

    On Linux the UI is broken and doesn't show time remaining for the ban for when Normal or Ranked is selected, you can still see it if you select the Seasonal Ranked:

    drDfUzA.png

    It's a bit annoying especially if you don't know that it shows up in Seasonal Ranked.

  4. #4
    Basic Member
    Join Date
    Jul 2013
    Posts
    6
    Quote Originally Posted by Maiku View Post
    Also to contribute something more than this vague bug report, here's another thing:

    On Linux the UI is broken and doesn't show time remaining for the ban for when Normal or Ranked is selected, you can still see it if you select the Seasonal Ranked:

    drDfUzA.png

    It's a bit annoying especially if you don't know that it shows up in Seasonal Ranked.
    the same is on windows as well

  5. #5
    Basic Member
    Join Date
    Jul 2017
    Posts
    2
    Faced same problem after latest patch. Last week there were no problems with connection. 24h BAN is an outrage.

  6. #6
    Basic Member
    Join Date
    Jul 2013
    Posts
    6
    Quote Originally Posted by Nereid View Post
    Faced same problem after latest patch. Last week there were no problems with connection. 24h BAN is an outrage.
    outrage is 24h ban for 2 days in a row

  7. #7
    Basic Member
    Join Date
    Jul 2017
    Posts
    7
    I'm playing dota2 for 800+ hrs and never had concection problems all starts when new patch came out! Fix it. vavle just give some info about that u saw these post and ur working on the dota2 server problem its not interesting to play in favorite game dor compendium lvl and compendium and don't play it TY again guys from steam who said this saite!

  8. #8
    Basic Member
    Join Date
    Jul 2017
    Posts
    7
    Valve is it a last april jocke or something cuse in csgo everything Is fine why in dota2 is problems. TY

  9. #9
    Basic Member
    Join Date
    Jul 2017
    Posts
    1
    I'm facing the same problems here along with a lot of other people around the world and it started almost for 3 or 2 day so it's not a CONNECTION ISSUE it's something from game itself
    i'm already taking my secend 24h ban for this bug/problem
    i can't play the game at all please some one take a look at our problem in dota2 develop team
    i'm already taking my secend 24h ban for this bug/problem

  10. #10
    Basic Member
    Join Date
    Jul 2013
    Posts
    6
    Same problem. 24h ban for second time in a row. internet connection is good, tried to ping closest servers from CMD, got this:
    "Ping statistics for 146.66.156.2:
    Packets: Sent = 33, Received = 23, Lost = 10 (30% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 9ms, Maximum = 50ms, Average = 11ms"
    "Ping statistics for 146.66.152.2:
    Packets: Sent = 27, Received = 27, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 32ms, Maximum = 57ms, Average = 34ms"

    for some reason for one server there is packet loss
    also this problem started several days ago. please look in to it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •