Results 1 to 5 of 5

Thread: Dota2.exe has stopped working

  1. #1

    Dota2.exe has stopped working

    A few days ago I had a power cut while playing Dota 2. And now I'm having constantly crashes of the game. It occurs around 1-4 mins in game time, no dumps founded, and console showed nothing when game crashed.

    Progress so far:

    1' verified integrity, add -autoconfig options
    2' reinstalled the game
    3' updated gpu driver
    4' remove cloud files

    none of above worked. But when I tried offline mode (open directly from the folder without starting steam), it seemed working well (tested for like 45 mins). For other games like civ, xcom, witcher 3, after the power cut, they are working well so I don't think it's a hardware issue for now.

    Any advice will be greatly appreciated.

  2. #2
    Basic Member
    Join Date
    Sep 2011
    Posts
    791
    Please provide the following:

    - a crash dump (in the folder where you've manually launched DOTA, there should be some dota2_2017_.._.mdmp files - zip archive the latest after sorting by date and attach it to your post),
    - a dxdiag report in text form (Winkey + R and enter dxdiag, then click on Save all Information..)
    - a list_my_programs.bat output from your Desktop (use download button on pastebin then run the script)

  3. #3
    Hi Gozuu, thanks for helping!
    There is no dump files from
    .. \Steam\dumps\*.dota2*.dmp
    .. \Steam\steamapps\common\dota 2 beta\game\bin\win64\dota2*.mdmp
    .. \Steam\steamapps\common\dota 2 beta\game\bin\win32\dota2*.mdmp.

    Generally when my Dota 2 crashed and disappeared, there is a dump file, but this time, it's unresponsive, kind of different. I attached my dx processes files. Thank you again for generous help.
    Attached Files Attached Files

  4. #4
    Basic Member aveyo's Avatar
    Join Date
    Aug 2012
    Location
    EU West
    Posts
    2,922
    It's hard to pinpoint an exact cause even with an actual crashdump file. Without it, it's even harder.
    Luckily, dxdiag reports DOTA crashing because of ASProxy64.dll - that's probably Astrill VPN
    Plenty of VPN software are incompatible with Steam and games. You need to completely uninstall this software.

    Other possible issues:

    Virtual Audio Cable
    - can cause crashes due to conflict with Steam voice and audio device detection in DOTA

    DAEMON Tools Lite
    - known program causing issues with Steam and games (specially if installed sptd driver)

    Razer glorified spyware bundle "in-Game Engine" & "GameScannerService" installed
    - Windows_key+X -> Command prompt(Admin): sc stop "Razer Game Scanner Service" &sc config "Razer Game Scanner Service" start= disabled
    - There should be an option in their settings to turn off "in-game engine", not sure it actually works
    - I would simply purge all Razer crap - the hardware works fine without any of these, but first start by uninstalling Razer Chroma SDK and keep just Synapse.

    SteelSeries Engine 3
    - not bad per-se, but it's gamestate integration can cause issues, and it can also conflict with Razer software

    Mixing gaming with developing / professional software on the same machine
    That's a huge no! Why? Examples from your list:
    - USB devices used for developing can be incompatible with Steam and games and must be unplugged
    - Some Citrix stuff is proven to cause crashes in Steam and games
    - Microsoft Visual Studio can activate appverifier / verifier (driver) / debugging libraries for directx and that can also cause crashes and reduced performance in Steam and games
    Dual-booting, vhd-boot, virtual machines are all solutions for this problem.

  5. #5
    Thank you for your help Aveyo! I removed Astrill and it seems work now.

    And thank you for extensive advice on software/games. I'm getting a new laptop soon, so I get I can use my desktop for gaming only.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •