In the OSX control panel, I have it set to put the screen to sleep if the mouse pointer is in the lower left corner. Even though DotA 2 is running fullscreen, when I put the pointer there to pan the map, the screen goes to sleep.

My current workaround is to disable the hotcorner any time I'm playing then reenable it when I'm done.