Results 1 to 3 of 3

Thread: Invoker Key Lag

  1. #1
    Basic Member
    Join Date
    Jun 2012
    Posts
    4

    Invoker Key Lag

    Summary:
    This Bug happened only once through my entire dota2 career (playing since 2012), but is game breaking and ruined the match for everyone in my team since i was not able to play anymore.
    I was playing as Invoker, around level 16, me and my team engaged in a teamfight with the enemies and i was able to cast my spell combos as always, but suddenly after the teamfight i wasn't able to invoke anything. My keys started working really slow, just like my orb keys were lagging or something similar. I though it was keyboard's fault (i have a corsair k95 RGB, if this makes any difference).
    If I press a combination to cast deafening blast (qwe for example) the game would not record the key pressed and it just does nothing or change only one orb, messing up all the casting.
    Trying to figure out the problem i noticed that if i pressed the key really slow (like keeping 1 key pressed for 4 to 6 second) the key would get recorded, but it was totally unplayable (i suspect this is due to my keyboard key repeat configuration, I suppose that at some point during the 4 to 6 second press the game records the key being pressed and performs the action).
    As soon as i noticed the problem I paused the game and tried to restart my pc, hoping the problem was on my end. Pc restarted, rejoined but sadly the problem was still there (i tried to type in the team chat "qwe", and it typed well, so i realized it was not on my end).
    From there i had no chance to fix the problem, tried my best but we ended up losing, of course. I looked on google to see if someone had similar issues and i read about Legacy key problem, but i'm not sure that was the same thing.
    Want to make it clear, casting spells (My two spells on invoker are binded to F and G) or using items did not have any delay and they were working good as far as I can tell.

    Repro Steps:
    1. start dota 2 match
    2. pick invoker
    3. level up to 16 (this is the level i was when the problem occurred)
    4. start a teamfight
    5. i dont know what exactly caused the problem to be honest. i guess it might be some strange combination of actions that happened during the teamfight. I had a forge spirit selected a bit before the teamfight if it makes any difference.

    Result:
    After the teamfight you can see me (below in the link at the moment the bug happened) trying to cast spells but only getting coldsnap or icewall (because keys were lagging and i was all on Quas). I then paused and restarted.
    When i press the keys to change orbs either nothing happens or it happens only partially after a long delay (5-10 seconds). For example, let's say i'm using QQQ robs: if I press WEE (chaos meteor), either i get no orb switch, or i get only partial orbs switch after a long delay (like QQW). I noticed that most of the times(but not all the times) only the first input get registered correctly.


    Expected Result:
    As an invoker I should be able to switch orbs to invoke spells quite quickly.

    I will leave the match ID with the timestamps here so you can check out what happened

    You can clearly see how my reactivity changed from this:
    dota2://matchid=5203675010&matchtime=1381

    to this (moment of teamfight, then disconnection to restart pc, watch for 5 minutes, you'll also see me desperately trying to switch orbs manually with the mouse :P):
    dota2://matchid=5203675010&matchtime=1756

    I can confirm that my keyboard was working fine (except for the ingame orbs switch): during the match i tried to search on google for a fix without any problem and also i replied to my teammates on dota 2 explaining the problem.

    Before posting this i tested out invoker in practice lobby and the bug seems gone now.

  2. #2
    Basic Member
    Join Date
    May 2015
    Posts
    4
    I noticed that Smart Double Tap on D key doesn't work at all, so I can't use Alacrity on myself or Cataclysm. F or any other key works as intended.

  3. #3
    Basic Member
    Join Date
    Apr 2013
    Posts
    6
    It happend exactly the same thing to me just 20 min ago.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •