Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19

Thread: [Confirmed] Relocate Camera Focus

  1. #1

    [Confirmed] Relocate Camera Focus

    So first it was Wisp's ulti not showing on minimap. Now it's when you ulti with wisp+friend, the screen goes to where u teleported FROM, not where you teleported to.

  2. #2
    Basic Member
    Join Date
    Dec 2011
    Posts
    11,187
    never happened to me.
    Make sure to read the Forum Rules as well as the stickied Threads of the Forum Section you are posting in.

    Contributions i'd like to highlight:
    My Suggestion: Coaching System
    My Sticky: Intended Changes List
    My Challenge: Completely Fixed Hero Challenge: Skywrath Mage

  3. #3
    Basic Member
    Join Date
    Jul 2012
    Posts
    12
    Quote Originally Posted by Shinrat3nsei View Post
    So first it was Wisp's ulti not showing on minimap. Now it's when you ulti with wisp+friend, the screen goes to where u teleported FROM, not where you teleported to.
    Summary:
    When using relocate, sometimes Game-Camera stays at the point you ported from.

    Repro:
    1) Level up Wisp lvl 6 and cast relocate
    2) leftclick (or rightclick) as fast as you can on the ground whie the port animation is shown

    Result:
    Sometimes the cam doesnt jump with you

    Expected:
    Cam should jump every time to the location you portetd to.

  4. #4
    Basic Member
    Join Date
    Dec 2011
    Posts
    11,187
    added to sticky.
    Make sure to read the Forum Rules as well as the stickied Threads of the Forum Section you are posting in.

    Contributions i'd like to highlight:
    My Suggestion: Coaching System
    My Sticky: Intended Changes List
    My Challenge: Completely Fixed Hero Challenge: Skywrath Mage

  5. #5
    Basic Member
    Join Date
    Nov 2012
    Posts
    8

    [Confirmed] wisp camera panning bug when relocate

    sometimes when you use relocate the camera does not pan/snap to the correct location - it instead pans to the location where wisp was before the relocate (so if your camera was on the location you are teleporting to, you are panned back and you end up walking to a random area if you are spamming right click). i have no idea how to reproduce this bug but it happens for about 1 in 8 relocates (so its very common in every game) and fuks up our gank completely, its really annoying.

    i will try to get a replay and timestamp but i still don't know what the actual cause or repro is. im usually at fountain when this happens (not always) and it snaps back to the fountain instead of snapping to my relocate location

    surely other wisp players have experienced this and can provide more feedback?
    Last edited by mingzie; 11-16-2012 at 09:48 PM.

  6. #6
    Basic Member Kaneomanie's Avatar
    Join Date
    Oct 2012
    Posts
    694
    I agree the camera isn't jumping reliably in various situations.

    You could always have the camera follow your hero while relocating thus it won't happen, but it's a kinda crappy solution since you cant see around you properly with the camera stuck on you until you unlock the camera again.

    Maybe a checkup on the range of your current camera position to your new hero position could help, if it's within a certain radius the camera shouldn't jump, thinking about ~800 units from the center of the screen should be fine.

  7. #7
    Basic Member
    Join Date
    Nov 2012
    Posts
    8
    im trying to find a replay from player perspective but it seems like it doesn't show. i will have to wait for a certain situation where this happens and timestamp/match ID it.

    that sounds like a good solution.. the current spell is pretty gg.. not so much that it snaps ur camera for absolutely no reason because your camera will/should be where you relocated anyway (and screws up your positioning), but that it DOESN'T even do its job properly. ive missed a shtload of ninja kills and got uncoordinated because of the camera just snapping to a random location that i didn't even relocate to lol.

    please allow us to toggle this lol.. or do it only for the player that is being tethered. the above suggested solution seems like it would work well. right now, the spell is doing something that sounds good on paper but fukks everything up (and its bugged which is even worse - i don't mind the current concept *that* much, just that its not working as intended, i never had this issue in dota 1 and the camera always snapped as expected).

  8. #8
    Basic Member GGreen's Avatar
    Join Date
    Oct 2012
    Posts
    56
    I approve. I want to start thread like this but was too lazy. Btw I think there is no need for camera automove or at least make this can be disabled.

  9. #9
    Basic Member Rainer's Avatar
    Join Date
    Dec 2011
    Location
    Somewhere
    Posts
    725
    i started a thread long ago for this but nobody comments there
    http://dev.dota2.com/showthread.php?t=58100

  10. #10
    Basic Member GGreen's Avatar
    Join Date
    Oct 2012
    Posts
    56
    Your title is incorrect. This one actually about "camera moving", not "camera not moving".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •