May have found a solution. Click on the weblink or just look at this post
That weblink is my account from playdota and i asked the forums for help, I had the same problem as well.
Someone answer my thread and send a link to this post and found other people had same problem.
Then i somehow manage to may have found the solution myself.

HOWEVER i did this solution against bots so yeah...

http://www.playdota.com/forums/showthread.php?t=1030549
Got a solution for anyone who have this problem. (Just found it right now.)

When start dota 2 and you appear in the menu section,
click settings,
video,
display mode,
Window or borderless window(choose whatever.) <-- smaller version of playing dota 2
You can go to other programme without pressing windows and still see yourself playing

I hear people, the blur happens after they join the game(same thing happens to me), well then
do the same thing and start a game.
Then if the blur comes or not, just go back to the main menu,
do the same thing however now click on fullscreen.
This would work and the blur will go.

That weblink is my account from playdota and i asked the forums for help, and i somehow i think may have found the solution myself.


I gave the same answer to other links.

http://dev.dota2.com/showthread.php?...735#post321735
http://www.playdota.com/forums/showthread.php?t=1030549