Page 5 of 5 FirstFirst ... 3 4 5
Results 41 to 47 of 47

Thread: Submit an item not cooperating

  1. #41
    Basic Member
    Join Date
    Aug 2012
    Posts
    26
    Some parts missing here:

    How did you get to just the sword and two bones?
    Did you import the kunkka SMD or OBJ? (probably SMD since that has the bones, but not sure)
    That looks like you imported Kunkka's model with Z axis up :S Edit: Nvm on this part, I'm not sure how you set blender's Y axis to up though.

    Sorry I'm so confused =/

  2. #42
    Basic Member Nemozini's Avatar
    Join Date
    Dec 2011
    Posts
    340
    I extracted his model using GFScape. Decompiled it and imported the decompiled SMD into blender. You need to import it with Y-axis up , so it would look upright on the Z-axis in blender. Once you are done setting up your model, you need to export it back to Y-axis for it to work in game.

    You are confused because I'm not using models provided here http://www.dota2.com/workshop/requirements/ which are already on the Z-axis it seems. Decompiling the MDLs is messy but I find the separated SMD easier to work with than the requirements page model.

    Kunkka's SMD provided on the requirements page + decompiled sword (blue one) SMD from Dota 2 files.



    If you want to work with the model they provided on the requirements page
    The sword is shifted a bit to the left. You can delete the rest of his body and its bones. Keeping the sword bone. It would still work even with that shift. Once you cleaned up the rest of his body , replace his sword with yours and export to SMD.

    And I'm a noob , someone might have a better way. but that what works for me.

  3. #43
    Basic Member
    Join Date
    Aug 2012
    Posts
    26
    ...sigh

    Okay, so here are the *exact* steps I just tried. Maybe you can tell me what I'm doing wrong.
    * Open my model, import Kunkka SMD
    * Select root and sword bones in Kunkka SMD, select inverse, delete
    * move my model (just vertices, not in object mode) up to rough sword position
    * Merge my model and kunkka model
    * Delete rest of Kunkka model (select vertice on my model, Ctrl-L, Select > Inverse, Delete)
    * Import Kunkka OBJ file
    * Align my sword rotation with the rotated sword in that
    * Delete all of the models I just imported (back to just my sword and two bones
    * Select all of the vertices on my mesh, find the "sword" vertex group, and assign those vertices to it
    * Export as SMD (there is no option for up axis for me in SMD export :S)

    Your sword SMD file works fine for me though. Not sure why.

  4. #44
    Basic Member Nemozini's Avatar
    Join Date
    Dec 2011
    Posts
    340
    Easier with pictures :P .. but I feel you are doing steps twice

    Why import kunkka twice obj and smd?

    Export SMD from the scene tab not from File>Export ... you will see options there.

  5. #45
    Basic Member
    Join Date
    Aug 2012
    Posts
    26
    SMD+OBJ because the provided SMD doesn't store model rotations and the OBJ doesn't store bones :P

    Will check scene tab.

  6. #46
    Basic Member
    Join Date
    Sep 2012
    Posts
    2
    Hello,

    I am having the same problems using Clinkz. I did all the steps mentioned, also tried different methods, but the bone still won't attach. I created a helmet and I am attaching it to clinkz's bone named 'head'. Even if I export only the bone and the mesh, it won't work! :S
    May this be a bug with clinkz's bone names?

  7. #47
    Basic Member
    Join Date
    Sep 2012
    Posts
    2
    Found the error. I don't know why, but the bone would be exported with the name "root" instaed of "head". You can open the .smd exported file and change it if needed!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •