Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15

Thread: Dota 2 Open mic Problem.

  1. #11
    Basic Member
    Join Date
    Dec 2011
    Posts
    9
    Quote Originally Posted by Berra_la View Post
    Until valve adds an option for choosing your recording device (like we can with speakers) the only thing you can try is to mess around with things "outside" of Dota.
    Got another mic you can try?
    Can you use another contact to plug your mic into (front, line in, mic, etc.)?
    Any settings in windows or your sound cards control panel?
    Basically anything that might change how Dota detects your sound devices.
    I have 3 other headsets and i have this problem with all three. Iv'e also tried this without a headset and with a actual Mic. and a Webcam. Neither worked.
    iv'e used each headphone and mic jack on my pc front, and back. that didn't have an effect either. Every time I check the threshhold, The green bar will only move when it hears sound. And not my mic.

    This is legit infuriating

  2. #12
    Basic Member
    Join Date
    Nov 2013
    Posts
    8

    I am having the same issue

    I would love some help on this problem. I'm experiencing the same thing.

    I'm running a mac, 10.8, dota 2 runs great, can't get mic to work.

    same exact symptom.

    i have my headset working IN EVERY OTHER APPLICATION so:

    1) my headset and mic are working

    2) my system is seeing my headset mic as my line-in input on my computer and so there is no issue with my settings in system preferences

    SOOOOOO...

    where's the problem? it's gotta be dota 2.

    But there are no settings for addressing this issue within dots 2.

    any help? Prease?

  3. #13
    Basic Member
    Join Date
    Dec 2013
    Posts
    1
    i had the same problem but i have fixed it by going to steam then going to VIEW>SETTINGS>VOICE there you can choose the mic that the games will use

  4. #14
    Basic Member
    Join Date
    Apr 2016
    Posts
    4
    YEEEEEEEESSSSSSSSSS I FINALLY SOLVED THE PROBLEM!!!

    ALL THESE BECAUSE OF ONE THING:

    OPEN MIC TRESHOLD!!!

    IF YOU JUST LET IT BE LIKE %6-10-15 YOUR MIC WILL BE OPEN, IF YOU MAKE IT MORE THEN IT WILL TRY TO GET ALL THE SOUND AROUND YOU AND IT WILL NOT WORK!

    I HOPE THIS HELPS, SORRY FOR MY BAD ENGLISH GUYS!

  5. #15
    Basic Member
    Join Date
    Apr 2016
    Posts
    4
    Quote Originally Posted by unkamajik View Post
    Hey guys, I have a problem and it's very irritating. My mic doesn't work in dota 2. But it works in skype, vent etc. etc.

    Now before you start flaming and say, "look for related post, theirs more then one".

    I have, Iv'e looked up this problem for more then 10 hours. Not in one sitting, but Iv'e wasted a lot of time trying to fix this... And nothing is working

    Some things you might want to know before you try to solve it for me....

    - yes.. its plugged in
    - no... its not muted
    - My microphone works properly in mostly every other application such as vent, mumble, skype, ts, hon and sc.
    - yes, my Steam chat settings are set, and I can hear my self with the settings.

    A few things I should add. The Open Mic Threshold seems to be picking up my Master Volume through out my PC. I have no way of controlling this through out the game AT ALL. Unless i'm blind and I can't find it.

    I honestly suggest a microphone output option in dota 2. An option like this is in every application, And people have more then a few mics hooked up to their PCs. (via headset and web cam). I'd like to be able to choose which mic i'm able to use ingame. It would take a huge load of my shoulders instead of banging my head on the wall wondering why DOTA2 thinks my master volume is my Microphone Output.


    As a disclaimer, My stream chat is set properly to my microphone... not my master volume. People said dota 2 takes the settings off of steam options, but not for me. (this is what I heard, not sure if its factual)

    Thanks, and i appreciate any help. I just can't play this game at all with out being able to communicate. Typing ruins my early game with last hits and takes a decent amount of time out of what i really need to focus on.

    I'm the last person to actually make a post, I'm pretty stubborn and want to know the solution ASAP by googling. But god... I can't find a single solution.

    and If someone posts me to the link with the so called console fix, please dont. It doesn't work.
    Check my reply dude. Hope it will help you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •