Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: command+q quitting the game

  1. #1
    Basic Member
    Join Date
    Jul 2013
    Posts
    3

    command+q quitting the game

    hello,

    i am attempting to make the switch from heroes of newerth to dota2 now that it is finally on mac. on hon, item use was generally "command+q" for item 1, "command+w" for item 2, etc. now that I attempt to do that on dota it quits the game because the game does not override the quit command.

    is there any way that you could disable this command? thanks!

  2. #2
    Basic Member
    Join Date
    Mar 2013
    Posts
    15
    if u can try using alt/option not "command" if i not get a windows keyboard

  3. #3
    Basic Member
    Join Date
    Nov 2012
    Posts
    4
    Quote Originally Posted by past_cool View Post
    if u can try using alt/option not "command" if i not get a windows keyboard
    That's a workaround, but this really is something that should be fixed in the client. Completely killing the game in the middle of a match is really bad — it shouldn't happen just because you fat-fingered a key combo.

  4. #4
    Basic Member
    Join Date
    Jul 2012
    Posts
    194
    +1, the usual application shortcuts (cmd q, h, m) should be disabled in-game. They could be enabled back in menu though.

  5. #5
    Basic Member
    Join Date
    Jul 2012
    Posts
    1
    +1, as for all keyboard shortcut that can throw you out of the. Or mabye any shortcut at all during a game (except the cmd+tab?).
    Or make it a general option?

  6. #6
    Basic Member Lord_Talron's Avatar
    Join Date
    Feb 2012
    Location
    Cornflake, Arkansas
    Posts
    3,175
    would be really nice, i am used to the full key functionality of my emulator

  7. #7
    Basic Member
    Join Date
    Dec 2011
    Posts
    4
    +1, because sometimes happen to press cmd+q and quit application.
    MacBook Air
    13-inch, Mid 2013
    Processor: 1.3 GHz Intel Core i5 (Haswell)
    Memory: 4 GB 1600 MHz DDR3
    Graphics: Intel HD Graphics 5000 1024 MB
    Software: OS X 10.8.4 (12E3067)

  8. #8
    Basic Member
    Join Date
    Nov 2011
    Posts
    48
    Meanwhile, you can just disable the cmd+q for Dota 2.
    http://www.quora.com/How-do-I-disable-Command-q-in-OS-X

  9. #9
    Basic Member
    Join Date
    Jul 2013
    Posts
    3
    Quote Originally Posted by LeGoLaSSS View Post
    Meanwhile, you can just disable the cmd+q for Dota 2.
    http://www.quora.com/How-do-I-disable-Command-q-in-OS-X
    this doesnt really work, they dont allow you to assign shortcuts to Dota 2, only Steam. also, the override doesnt even seem to work for Steam. either that or im doing something terribly wrong.

  10. #10
    Basic Member
    Join Date
    Jul 2013
    Posts
    3
    just to reiterate, command key functions ruin the game [for me at least]. in addition, the hot corners on macs need to be overridden as well because every time i put my mouse in the corner of the screen it brings me my dashboard and that is not a function id like to give up to play dota. while i understand that there are intricate ways of going about these things, an organic fix would be much better.

    and also, while you might be able to disable command+q, you cant enable the use of command keys as available hot keys for items and such in the game.

    i appreciate the developers taking their time to look into these things!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •