Results 1 to 5 of 5

Thread: [Resolved] Enchantress ultimate (Impetus) staying on after Bloodrage

  1. #1
    Basic Member
    Join Date
    Jun 2013
    Posts
    22

    [Resolved] Enchantress ultimate (Impetus) staying on after Bloodrage

    Hi,

    I was playing a match yesterday (ID: 243232352), when at around 30:06, as I was attacking Bloodseeker; he cast Bloodrage on me and whilst I was silenced the box that shows Impetus started showing an orange circular motion round the side. This meant that the ultimate was on for every attack. I restarted whilst in-game, but my ulti stayed on for the rest of the match.

    I also, noticed that I seemed to have a Wildwing associated with the units under my control. This was sitting in the Dire jungle but it was Drow that controlled it via HotD, but I could tab to it, but not control it

  2. #2
    Basic Member
    Join Date
    Dec 2011
    Location
    Shanghai/Hong Kong
    Posts
    2,880
    cant turn off autocast impetus? err... have u tried to use hotkey(default is alt+r i think)?

  3. #3
    Basic Member
    Join Date
    Dec 2011
    Posts
    1,903
    Going by his description I think he doesn't know what auto cast is to begin with, because if he knew he'd just say 'autocast was turned on'. In other words I presume he just did not know how to turn it off, namely by just right clicking the ability icon.

  4. #4
    Basic Member scorra2's Avatar
    Join Date
    Jan 2012
    Posts
    364
    Pudge can't turn off rot when silenced, but that is WAD.

  5. #5
    Basic Member
    Join Date
    Jun 2013
    Posts
    22
    Thanks Eric37073. I tested it and that is what must have happened. I have never seen the autocast on before. If i'm using an Orb? effect like Burning Spear or Frost Arrows, I tend to just click the Q, W key or whatever and target the enemy. I can see one of the reasons why autocast must be useful in the respect.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •