Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 21

Thread: Dota 2 for Mac should block Hot Corner!

  1. #11
    god, please fix this,..also please fit the game to a mac keyboard and block shortcuts such as cmd + Space , cmd + Q and so on..I really wish to use the cmd key in certain combinations as it is far way better than trying the alt or ctrl key
    Last edited by UserFirnedlyMusic; 08-13-2013 at 09:37 PM.

  2. #12
    Basic Member
    Join Date
    May 2013
    Posts
    4
    for the Hot Corners issue I made myself a little dialog box with Apple Scripts.

    http://www.mediafire.com/download/90...nok/Expose.zip

    that should make it easier for you guys for now!

    I take no credit in the actual code! pulled all that from the Internet and just compiled it into a little program.


    EDIT: few seconds after posting I realized that this will only work with my pre-set options for the corners.
    of there is any interest I could write a little post how I made it and how you can do it to for your settings!
    Last edited by Kyu; 08-15-2013 at 07:44 AM.

  3. #13
    Basic Member
    Join Date
    Aug 2013
    Posts
    2
    Oh, that is the only reason why I have registered here. In all other cases mac port is perfect (latest patches is really improves FPS, and almost illuminate crashes)
    But please, oh no, PLEASE, fix this ugly bug with Hot Corners!

  4. #14
    Basic Member
    Join Date
    Aug 2013
    Posts
    2
    And sorry for my bad english

  5. #15
    Basic Member
    Join Date
    Aug 2013
    Posts
    1
    Please fix this. It is very annoying to have to switch off hot corners and switch them back on again. It would also be nice to have hotkey profiles for those who play with multiple input setups.

  6. #16
    Basic Member
    Join Date
    Aug 2013
    Posts
    2
    I've been playing DOTA2 on mac, too and this problem is so annoying (and it's not the only problem/bug this game has on OS X).
    I use Hot Corners a lot but while playing the game I have to manually disable each one of them and then again after the game re-enable them.

    Please fix it, thanks.

  7. #17
    Basic Member
    Join Date
    Sep 2013
    Posts
    1
    Many macintosh users use hot corners. If the mouse pointer reaches the corner it makes a command: show desktop, show all windows etc.
    In game if hot corners selects all windows it switches the 'desktop window' instead of 'dota 2 window'. This time the game is unable to control, i have to choose all windows again and select dota 2 window again. and some click to enable the game window.
    In starcraft 2 this bug is fixed if it helps u to check.
    So should disable all sensitive parts of the screen and only with cmd + tab would allow to switch to desktop.

  8. #18
    Basic Member
    Join Date
    Oct 2013
    Posts
    4
    Yeah!!! Please, Valve, fix it!!!!

  9. #19
    Basic Member
    Join Date
    Nov 2011
    Posts
    11
    I found another convenient workaround (especially since the scripts don't work under mavericks anymore).
    The idea is that hot corners (in general) will only activate when you push a button along with it.
    In short: when setting up your hot corners in the settings push cmd, shift, ctrl or option key while selecting what the corner should do.
    This also avoids accidental activation of the hot corners.

    Here is where I found it and a detailed description how to set it up:
    http://www.macobserver.com/tmo/artic...se-hot-corners

  10. #20
    Basic Member
    Join Date
    Nov 2013
    Posts
    26
    Yes, its not so hard to implement...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •