Results 1 to 10 of 10

Thread: Audio Issue - Settings & Announcers

  1. #1
    Basic Member
    Join Date
    Jul 2013
    Posts
    1

    Audio Issue - Settings & Announcers

    Ever since installing the client on my Macbook Pro I've been unable to get announcers to work, default or the one that I've purchased. Unequipping them, switching to default, nothing makes them work.

    This could be because of my audio settings not saving changes as well. When I go into audio, even if I choose to restore to default settings, the unit speech will change to "Off" if I leave settings.

  2. #2
    Basic Member
    Join Date
    Jul 2013
    Posts
    7
    no sound is a known issue. I dont have any sound in game since dota test on my MBP ether

  3. #3
    Basic Member
    Join Date
    Jul 2013
    Posts
    4
    I have the EXACT same problem on my iMac

  4. #4
    Basic Member
    Join Date
    Jul 2013
    Posts
    34
    as described here https://github.com/ValveSoftware/Dota-2/issues/437 you can set unit speach by the following command:

    dota_speech_level 2

  5. #5
    Basic Member
    Join Date
    Jul 2013
    Posts
    4
    Yes, I've tried that and as soon as I start DOTA 2, the file resets itself to 0.

  6. #6
    Basic Member
    Join Date
    Jul 2013
    Posts
    34
    Quote Originally Posted by BluFoot View Post
    Yes, I've tried that and as soon as I start DOTA 2, the file resets itself to 0.
    open console and enter the command there, it was saved for me.

  7. #7
    Basic Member
    Join Date
    Jul 2013
    Posts
    4
    How do I do that? I'm brand new to the game...

  8. #8
    Basic Member
    Join Date
    Jul 2013
    Posts
    4
    Hooray the console trick worked, thanks!

  9. #9
    Basic Member
    Join Date
    Jul 2013
    Posts
    34
    Quote Originally Posted by BluFoot View Post
    Hooray the console trick worked, thanks!
    don't get too excited, it might be force-disabled for a reason (e.g. certain audio files might crash the client). I'd recommend not to use the options you can't enable from the menu until the client is stable.

  10. #10
    try dota_speech_level 1 or in dota2 setting set unit speed to event.
    (All doesn't seem to work, whenever you change to all, it changes back to off)
    It works for me on "event"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •